Bug 402131 - No filter applied to incoming mail
Summary: No filter applied to incoming mail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-28 03:56 UTC by Matthew Saltzman
Modified: 2008-01-22 16:02 UTC (History)
1 user (show)

Fixed In Version: 2.12.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-22 16:02:09 UTC


Attachments (Terms of Use)

Description Matthew Saltzman 2007-11-28 03:56:41 UTC
Description of problem:
I have several filters defined, but incoming mail is not filtered for either
spam or my filters.

Version-Release number of selected component (if applicable):
evolution-2.12.1-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Define filters and/or enable spam detection
2. Receive mail that should be filtered
3.
  
Actual results:
Messages sit in inbox waiting for me to move by hand or select and apply filters
with CRTL-y.

Expected results:
Messages are filtered into Junk or specified folders.

Additional info:
New in F8.  Evo in F7 worked fine.

Comment 1 Milan Crha 2007-11-28 13:28:07 UTC
Does this help?
http://www.go-evolution.org/FAQ#Why_do_my_mail_filters_not_work.3F

Comment 2 Matthew Saltzman 2007-11-28 16:03:18 UTC
No.

None of the rules have Stop Processing.  This is an Exchange account, but the
appropriate options are set and Bogofilter is enabled.  I have been using only
this client to read this inbox.


Comment 3 Matthew Saltzman 2007-11-28 16:04:11 UTC
Oh, and the settings were all inherited from F7, where filtering did work.

Comment 4 Rasmus Wiman 2007-12-18 10:07:09 UTC
I have exactly the same problem. Evolution, exchange, upgraded from FC7. Very
annoying.

Comment 5 Milan Crha 2007-12-18 13:26:50 UTC
I pushed an upstream patch to evolution-exchange-2.12.2-2.fc8, which is now in
updates testing. If you can, please try this package and let me know if it
helps. Thanks in advance.

Comment 6 Milan Crha 2007-12-18 13:33:21 UTC
Just for a record, patch is based on this mail:
http://mail.gnome.org/archives/evolution-list/2007-December/msg00076.html

Comment 7 Rasmus Wiman 2007-12-19 10:25:41 UTC
Didn't realise I had to get it with cvs, but now it works. This bug was an
absolute show-stopper for me. Thanks!

Comment 8 Matthew Barnes 2007-12-19 13:21:13 UTC
Closing as CURRENTRELEASE based on comment #7.

Comment 9 Matthew Saltzman 2007-12-19 13:55:58 UTC
Haven't seen this in F8 updates-testing yet.

Thanks.

Comment 10 Fedora Update System 2007-12-20 19:49:59 UTC
evolution-exchange-2.12.2-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evolution-exchange'

Comment 11 Matthew Saltzman 2007-12-23 03:15:19 UTC
Looks good so far.  Thanks.

Comment 12 Fedora Update System 2008-01-22 16:02:08 UTC
evolution-exchange-2.12.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.