This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 402151 - grub-install can't install to MBR on cciss devices
grub-install can't install to MBR on cciss devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Milan Zazrivec
:
: 429187 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 23:41 EST by Fabio Olive Leite
Modified: 2011-09-08 10:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0440
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:46:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to detect if disk and partition are the same, and install on MBR (562 bytes, patch)
2007-11-27 23:41 EST, Fabio Olive Leite
no flags Details | Diff

  None (edit)
Description Fabio Olive Leite 2007-11-27 23:41:13 EST
Description of problem:

While using the grub-install script, if specifying a base device 
of '/dev/cciss/c0d0', the script reports an error, yet claims to have finished 
successfully.

     [root@box ~]# grub-install /dev/cciss/c0d0
      expr: non-numeric argument
      Installation finished. No error reported.
      This is the contents of the device map /boot/grub/device.map.
      Check if this is correct or not. If any of the lines is incorrect,
      fix it and re-run the script `grub-install'.

      # this device map was generated by anaconda
      (hd0)     /dev/cciss/c0d0

How reproducible:

Always

Steps to Reproduce:

On a system with /dev/cciss devices (specifically an HP Proliant DL380) using 
the grub-0.97-13 package, run:

grub-install /dev/cciss/c0d0

Actual results:

The script runs, an error is displayed, and the script claims to exit 
successfully. The result is that GRUB is not actually installed, or is not 
installed to the MBR of the device provided.

Expected results:

GRUB should be installed as expected.

Additional info:

Proposed fix is attached as a patch.
Comment 1 Fabio Olive Leite 2007-11-27 23:41:14 EST
Created attachment 270681 [details]
Patch to detect if disk and partition are the same, and install on MBR
Comment 3 RHEL Product and Program Management 2007-11-27 23:44:25 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Peter Jones 2008-02-04 14:52:38 EST
*** Bug 429187 has been marked as a duplicate of this bug. ***
Comment 7 Peter Jones 2008-02-04 15:00:35 EST
Fixed in grub-0.97-13.1 .
Comment 9 Peter Jones 2008-02-07 16:30:30 EST
The fix breaks dmraid; need to respin this with a slightly different solution.
Comment 10 Peter Jones 2008-02-07 19:05:26 EST
Fixed again in grub-0.97-13.2 .
Comment 12 Carsten Clasohm 2008-02-14 04:03:33 EST
One workaround with grub-0.97-13 is to run "grub-install hd0". This works if hd0
is mapped to the correct cciss device in /boot/grub/device.map.
Comment 13 Milan Zazrivec 2008-04-02 04:34:10 EDT
Verified with RHEL5.2-Server-20080402.nightly / grub-0.97-13.2
on a HP Proliant DL360 system.
Comment 15 errata-xmlrpc 2008-05-21 12:46:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0440.html

Note You need to log in before you can comment on or make changes to this bug.