Bug 40226 - RFE: Please make switchdesk use intltool
Summary: RFE: Please make switchdesk use intltool
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: switchdesk (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-11 12:20 UTC by Christian Rose
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 20:47:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2001-05-11 12:20:13 UTC
Please make switchdesk use xml-i18n-tools.
This will significantly ease, among other things, the translation and
translation maintenance of the
.desktop file.

Comment 1 Bernhard Rosenkraenzer 2001-05-28 07:38:54 UTC
Since we have 2 frontends for switchdesk, using xml-i18n-tools in one of them 
wouldn't make much sense (the other would still need extra translations).

Since neither UI uses an xml file, xml-i18n-tools is the wrong tool for the 
job.


Comment 2 Christian Rose 2001-05-28 14:58:02 UTC
Then use xml-i18n-tools for both of them. If you only use it for .desktop files
translation, for example, xml-i18n-tools will only be a compile-time dependency.

And xml-i18n-tools is *not* only for XML translation. .desktop files are not
XML, yet xml-i18n-tools include logic for making translations of those easier
too. This was what I suggested. I never implied switchdesk used XML.

Comment 3 Christian Rose 2002-05-13 15:28:09 UTC
xml-i18n-tools is nowadays called intltool.

Comment 4 Mike A. Harris 2002-10-26 04:50:44 UTC
I've just been assigned this package and don't have an opinion on
the report just yet.  I figured I would send out a ping first to see
if the issue is still relevant in Red Hat Linux 8.0 or not.



Comment 5 Christian Rose 2002-10-26 07:40:23 UTC
Pong. It's certainly still relevant.
The only translations that switchdesk has in
/usr/share/applications/redhat-switchdesk.desktop on my RHL 8.0 system are the
hard-coded ones, and they're also wrongly encoded. Using intltool would not only
fix so that all existing translations are automatically pulled in, it would also
fix the encoding.

Comment 6 Ngo Than 2004-02-03 20:47:18 UTC
it's fixed in switchdesk-4.0.0, which is available in rawhide


Note You need to log in before you can comment on or make changes to this bug.