Bug 402531 - libwvstreams uses obsolete (and non-POSIX) sa_restorer
libwvstreams uses obsolete (and non-POSIX) sa_restorer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libwvstreams (Show other bugs)
8
alpha Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 06:03 EST by Oliver Falk
Modified: 2007-12-03 06:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 09:57:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-11-28 06:03:27 EST
From my build.log:
[oliver@gosa libwvstreams]$ cat .build-4.4-1.fc8.log |tail
utils/wvcrash.cc:96: warning: ignoring return value of 'ssize_t write(int, const
void*, size_t)', declared with attribute warn_unused_result
utils/wvcrash.cc: In function 'void wvcrash_add_signal(int)':
utils/wvcrash.cc:388: error: 'struct sigaction' has no member named 'sa_restorer'
make[1]: *** [utils/wvcrash.o] Error 1
make[1]: Leaving directory `/home/oliver/cvs/F-8/libwvstreams/wvstreams-4.4'
error: Bad exit status from /var/tmp/rpm-tmp.99427 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.99427 (%build)


From sigaction manpage:
<snip>
  The sa_restorer element is obsolete and should not be used.  POSIX does not
specify
  a sa_restorer element.
</snip>
Comment 1 Oliver Falk 2007-11-28 09:04:58 EST
Since it's obsolete. It's safe to remove that line - I think. Patch:
diff -up wvstreams-4.4/utils/wvcrash.cc.no_sa_restorer
wvstreams-4.4/utils/wvcrash.cc
--- wvstreams-4.4/utils/wvcrash.cc.no_sa_restorer       2007-11-28
12:03:43.000000000 +0100
+++ wvstreams-4.4/utils/wvcrash.cc      2007-11-28 12:03:53.000000000 +0100
@@ -385,7 +385,6 @@ void wvcrash_add_signal(int sig)
     act.sa_handler = wvcrash;
     sigfillset(&act.sa_mask);
     act.sa_flags = SA_ONSTACK | SA_RESTART;
-    act.sa_restorer = NULL;
     
     if (sigaction(sig, &act, NULL))
         fprintf(stderr, "Failed to setup wvcrash handler for signal %d: %s\n",
Comment 2 Ondrej Vasik 2007-11-28 09:57:38 EST
Thanks for report and patch. Just found that ubuntu included similar patch(with
memset for act struct - which is actually better) in July and that the problem
is still not reported to upstream. I will send information to upstream. Built as
libwvstreams-4.4.1-2.fc9 , closing RAWHIDE.
Comment 3 Oliver Falk 2007-11-28 11:47:18 EST
Can you please include in f8 as well!?
Comment 4 Ondrej Vasik 2007-11-29 04:15:02 EST
No problem, will do update to 4.4.1 today with this patch included...
Comment 5 Fedora Update System 2007-12-03 06:48:42 EST
libwvstreams-4.4.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.