Bug 402641 - Kazehakase won't run against xulrunner (gecko-libs 1.9)
Kazehakase won't run against xulrunner (gecko-libs 1.9)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kazehakase (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
: 440812 (view as bug list)
Depends On:
Blocks: FTBFS F9Upgrade
  Show dependency treegraph
 
Reported: 2007-11-28 08:16 EST by Martin Stransky
Modified: 2008-07-26 02:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.5.4-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 04:32:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb log of kazehakase (13.72 KB, text/plain)
2008-03-05 11:01 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Martin Stransky 2007-11-28 08:16:11 EST
Description of problem:

Kazehakase fails to compile against XUL Runner (gecko-libs 1.9) in rawhide. XUL
Runner will be a gecko-libs provider in Fedora 9 and all gecko-libs packages
have to be rebuilt aginst it. (see
http://fedoraproject.org/wiki/Releases/FeatureXULRunner).

Version-Release number of selected component (if applicable):
Comment 1 Mamoru TASAKA 2007-11-28 08:24:23 EST
I would appreciate it if you supply patches needed to build
kazehakase against xulrunner so that I can send it to upstream.
Comment 2 Mamoru TASAKA 2007-11-28 08:30:17 EST
Perhaps upstream won't try to adjust kazehakase to xulrunner until
"formal" xulrunner 1.9 is relased because

- Upstream told me that kazehakase should already support gecko 1.9
- Upstream perhaps don't not why some header files are removed
  and perhaps they are thinking that gecko 1.9 API is not freezed
  https://www.redhat.com/archives/fedora-devel-list/2007-November/msg01079.html
Comment 3 Martin Stransky 2007-11-28 08:36:19 EST
I'd like to help you with it but I have to port application from core first
(galeon/epiphany).

Anyway, you have a time, firefox-devel is still in rawhide and if the support is
planned by upstream you can rebase the package after official xulrunner release.
Comment 4 Alex Lancaster 2007-12-28 03:39:13 EST
(In reply to comment #3)

> Anyway, you have a time, firefox-devel is still in rawhide and if the support is
> planned by upstream you can rebase the package after official xulrunner release.

Unfortunately this is no longer the case, as firefox-devel has now been removed
from rawhide.
Comment 5 Alex Lancaster 2008-01-16 08:33:59 EST
tried a simple update of gecko-libs to 1.9 for xulrunner, but doesn't build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=31755

which seems to contract the assertion that gecko 1.9 works by upstream mentioned
in comment #2
Comment 6 Mamoru TASAKA 2008-03-05 11:01:14 EST
Created attachment 296892 [details]
gdb log of kazehakase

Well, now actually kazehakase (0.5.3-4.fc9) builds against
recent xulrunner (nightly20080304):

http://koji.fedoraproject.org/koji/buildinfo?buildID=41399

However when I
- install kazehakase-base, kazehakase
- launch kazehakase (type $ kazehakase)
- select "File -> New Tab"

Then kazehakase crashes. gdb attached, however I cannot figure out
where crash is happening from gdb log.
Gecko related codes are mostly under module/embed/gecko/.

Gecko maintainers, would you give me some help?
Comment 7 Mamoru TASAKA 2008-03-09 11:44:37 EDT
Umm... kazekahase seems to still be failing to find gtk_moz_embed_push_startup ()
symbol..
Comment 8 Mamoru TASAKA 2008-04-04 12:07:30 EDT
*** Bug 440812 has been marked as a duplicate of this bug. ***
Comment 9 Mamoru TASAKA 2008-04-07 12:34:43 EDT
scratch  build is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=554301

Again, actually kazehakase builds, but is broken completely for xulrunner
(just File -> open the new tab makes kazehakase crash).

I really appreciate gecko maintainers' help.
Comment 10 Bug Zapper 2008-05-14 00:02:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Fedora Update System 2008-06-25 11:02:25 EDT
kazehakase-0.5.4-5.fc9 has been submitted as an update for Fedora 9
Comment 12 Fedora Update System 2008-06-26 04:32:34 EDT
kazehakase-0.5.4-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-07-26 02:09:21 EDT
kazehakase-0.5.4-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.