This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 402671 - no soundcard when using xinit to open another X
no soundcard when using xinit to open another X
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 08:27 EST by Johnathan
Modified: 2013-03-05 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:21:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnathan 2007-11-28 08:27:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc8 Firefox/2.0.0.9

Description of problem:
I think this is a consolekit issue because of the permissions...

I have always used xinit -- :1.0 to open another X display to run games. With fedora 8 when I do this it says I have no sound card. I don't use pulse audio since I have hardware mixing support with alsa. My sound works fine on my normal desktop and ctrl+alt+F1-F6. I run aplay -l and it says there is no sound card when I am on the new X display. If I try to access /dev/dsp on the new X it says permission denied, but if I give /dev/dsp read/write access to everyone I can get sound that way. If I open a new display the same way as root I can access everything normally though.

If I am logged into the new X as a normal user and run system-config-soundcard (which requires root access anyway) it shows the sound card and plays sounds, but still no help in getting sound on that display for the normal user.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.ctrl+alt+F1
2.log in as normal user
3.xinit -- :1.0
4.aplay -l

Actual Results:
No sound card detected

Expected Results:
sound

Additional info:
Comment 1 Will Woods 2007-12-03 15:55:32 EST
'startx' should do the right thing with ConsoleKit. Could you try using 'startx
-- :1.0' instead?
Comment 2 Johnathan 2007-12-03 21:16:44 EST
startx -- :1.0 does not work. I get lots of errors like:
AUDIT: Mon Dec  3 19:52:46 2007: 12301 X: client 1 rejected from local host (uid
500)
  Auth name: MIT-MAGIC-COOKIE-1 ID: -1
Invalid MIT-MAGIC-COOKIE-1 key.

I tried to add a cookie by the normal:
xauth add :1.0 . `mcookie`
and still no luck.

If I run
startx -- :1
it will open and have soundcards, but it opens another gnome session which I
don't want.
Comment 3 Johnathan 2008-02-25 06:07:34 EST
I had found a work around that works somewhat.
I open the new display from ctrl+alt+f1 doing:
xinit -- :1.0
then I run a game like this from the new X display (ctrl+alt+f8):
sleep 2; ./ut2k4
then I switch back to ctrl+alt+f7 (normal desktop) real quick and wait for the
game to load. It will have full access to alsa devices and everything. If at any
point it releases the sound card or something it will say it can't find the
sound card again.
Comment 4 Bug Zapper 2008-11-26 03:43:54 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-01-09 00:21:52 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.