Bug 402681 - scim does not load when system language is en_US
scim does not load when system language is en_US
Status: CLOSED DUPLICATE of bug 243563
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 08:28 EST by Don Johnson
Modified: 2008-01-21 02:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 02:48:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified file xinput.sh which corrects problem (1.60 KB, patch)
2007-11-28 08:28 EST, Don Johnson
no flags Details | Diff

  None (edit)
Description Don Johnson 2007-11-28 08:28:25 EST
Description of problem:
scim does not load when system language is en_US. The user cannot access the
scim keyboard icon on the Gnome panel bar at the top. Consequently, the user
cannot do input in other languages; only tested for Japanese (scim-anthy) with
Gnome desktop. The reason that scim does load is because the file:
    /etc/X11/xinit/xinputrc
is never sourced on line 36 of file:
/etc/X11/xinit/xinitrc.d/xinput.sh
If the the token "en" is added to the hardcoded string on line 33 of this same
file, scim loads every time "X" is started. See line 33 of attached file. I am
not sure if this is the best way to fix the problem.

Version-Release number of selected component (if applicable):
Smart Common Input Method platform 1.4.5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Don Johnson 2007-11-28 08:28:25 EST
Created attachment 271301 [details]
modified file xinput.sh which corrects problem
Comment 2 Jens Petersen 2008-01-21 02:40:08 EST
Could you attach a diff patch instead please.
Comment 3 Jens Petersen 2008-01-21 02:48:04 EST
Nevermind this intentional.

You can turn on SCIM for en with im-chooser,
but you need to override with Custom -> SCIM.


*** This bug has been marked as a duplicate of 243563 ***

Note You need to log in before you can comment on or make changes to this bug.