Bug 402741 - (CVE-2007-1217) CVE-2007-1217 Kernel: CAPI overflow
CVE-2007-1217 Kernel: CAPI overflow
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
http://cve.mitre.org/cgi-bin/cvename....
impact=moderate,public=20070314,repor...
: Security
Depends On: 402751 402761 402771 402781 402791 402801 402811
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 09:11 EST by Jan Lieskovsky
Modified: 2010-12-22 16:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-22 16:16:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2007-11-28 09:11:40 EST
Description of problem:

Buffer overflow in the bufprint function in capiutil.c in libcapi, as used in
Linux kernel 2.6.9 to 2.6.20 and isdn4k-utils, allows local users to cause a
denial of service (crash) and possibly gain privileges via a crafted CAPI
packet.

This issue public via: 

http://bugs.gentoo.org/show_bug.cgi?id=170867


The reporter (Sune Kloppenborg Jeppesen <jaervosz@gentoo.org>) did not attach
a patch :o(.
Comment 5 Vincent Danen 2010-12-22 16:16:11 EST
This was addressed via:

Red Hat Enterprise Linux version 3 (RHSA-2007:0671)
Red Hat Enterprise Linux version 2.1 (RHSA-2007:0672)
Red Hat Linux Advanced Workstation 2.1 (RHSA-2007:0673)
Red Hat Enterprise Linux version 5 (RHSA-2007:0705)
Red Hat Enterprise Linux version 4 (RHSA-2007:0774)

Note You need to log in before you can comment on or make changes to this bug.