Bug 402831 - Unable to compile kernel
Unable to compile kernel
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
athlon Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 09:26 EST by Vincent
Modified: 2008-08-06 16:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 16:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent 2007-11-28 09:26:28 EST
Description of problem:
not able to compile modules for installed kernel

Version-Release number of selected component (if applicable):
Install script??

How reproducible:
every time same results - Very

Conclusion:
I think Anaconda is being tripped up by the AMD Athlon XP chip and the devel
package is not being installed. I did try installing the kernel-devel i686
package but it still didn't work.
I did try installing Fedora 7.91 and it worked properly on the AMD Athlon.

Steps to Reproduce:
1.Install Fedora 8 DVD on system with AMD Athlon XP CPU
2.
3.
  
Actual results:
devel files are not installed for kernel installed.

Expected results:
devel files are installed for kernel installed.

Additional info:
Systems used:

Desktop:
Asus A7V8X-X
AMD Athlon XP 1800+
512M RAM DDR1
NVidia MX 440 w/ AGP 8x 64M

Laptop:
Dell Inspiron 8600
Intel Pentium M 1.4 GHz
256M RAM DDR1
NVidia Go 5200 32M

After installing Fedora 8 on the desktop I noticed that when I went to install
the NVidia drivers it reported that the headers/devel package wasn't installed.
When I went to disable the firewall it reported that it wasn't able to uninstall
the module.
I next tried installing it on the laptop and did not get any error when
disabling the firewall, The NVidia driver installed with out any complaints, and
the source files where properly installed at /usr/src/kernels/2.6.23.1-42.fc8-i686
Comment 1 Chris Lumens 2007-11-28 09:59:46 EST
Which kernel packages do you have installed (rpm -qa kernel\*)?  Did you select
the development group to make sure that gcc was installed?  Can you attach
/var/log/anaconda.log and /root/install.log to this bug report?

Note You need to log in before you can comment on or make changes to this bug.