Bug 403161 - World of warcraft no longer runs
World of warcraft no longer runs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 11:51 EST by Jonathan Eskritt
Modified: 2007-12-09 05:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 05:31:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Eskritt 2007-11-28 11:51:43 EST
Description of problem:
I've been using wine to play WoW for over a year. my current system is an Althon
X2 4200+ with 1 GB ram and a Gforce 7900GT.

I was running Fedora 6 and wine 0.9.49 and WoW 2.3.0 until sunday with no
issues. I reinstalled the system with Fedora 8,  wine-0.9.49-1.fc8 and Nvidia's
100.14.19 driver. and now I'm having issues.

When I start in openGL mode I get "your 3d accelerator card is not supported by
World of Warcraft. Please install a 3D accelrator card with dual-TMU support".
If I start WoW in D3D mode I can get to the character screen but when I try to
enter the world I get the loading screen with music but the progress bar never
moves.

my glxgears reports 16000 fps or higher.

"glxinfo | grep direct"  reports yes

Version-Release number of selected component (if applicable):
0.9.49

How reproducible:
every time

Steps to Reproduce:
1. use wine to start world of warcraft in either opengl or d3d mode

  
Actual results:
in opengl mode the program produces an error dialog before ever launching. in
D3D mode the game launches, lets you log in and select a character, but locks up
on loading screen without the progress bar even starting, though the music still
plays.

Expected results:
game should launch and play

Additional info:
I'm using the nvidia drivers from livna:
kmod-nvidia-100.14.19-18.lvn8
xorg-x11-drv-nvidia-libs-32bit-100.14.19-4.lvn8
kmod-nvidia-2.6.23.1-49.fc8-100.14.19-18.lvn8
xorg-x11-drv-nvidia-100.14.19-4.lvn8
xorg-x11-drv-nvidia-devel-100.14.19-4.lvn8

and kernel kernel-2.6.23.1-49.fc8
Comment 1 Jonathan Eskritt 2007-11-28 15:20:47 EST
This seems to be a nvidia driver problem. I updated to the 169.04 beta drivers
and it the issue went away.
Comment 2 Mephisto 2007-12-07 03:35:22 EST
This does not seem to be an nvidia issue, but an issue with your old driver
installation. I'm playing WoW on 0.9.49 on F8 just fine.
Maybe you shouldn't use the livna package but the one from freshrpms, like i do :+

Note You need to log in before you can comment on or make changes to this bug.