This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 40329 - Fixed fonts not rendered with QT_XFT
Fixed fonts not rendered with QT_XFT
Status: CLOSED DUPLICATE of bug 37494
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-11 19:41 EDT by Will Newton
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 06:51:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Newton 2001-05-11 19:41:15 EDT
Description of Problem:

Fixed fonts don't work with QT_XFT=1. Setting QT_XFT causes all fixed/bitmap 
fonts to not be rendered.  It is also liable to cause a SIGFPE in XftOpenFont.


How Reproducible:

100%.


Steps to Reproduce:
1.  Install XFree86 4.0.3-x, qt-2.3.0-x, KDE-2.1.x
2.  Go to settings/look and feel/fonts/fixed font
3.  No fonts are available.

Non-Qt apps use fixed fonts OK.

Additional Information:

This bug has been around for a while (a month, maybe more).

The patch:

 XFree86-4.0.2-Xft-update.patch

(not applied in the latest src.rpm)

seems to stop the SIGFPE, but still no fixed fonts are rendered.
Comment 1 Bernhard Rosenkraenzer 2001-05-14 06:55:12 EDT

*** This bug has been marked as a duplicate of 37494 ***

Note You need to log in before you can comment on or make changes to this bug.