Bug 403331 - NM: cannot associate with AP when using WPA-PSK (wpa_supp can)
Summary: NM: cannot associate with AP when using WPA-PSK (wpa_supp can)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-28 19:12 UTC by Jurgen Kramer
Modified: 2008-10-20 14:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 14:46:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from NetworkManager --no-daemon (2.72 KB, text/plain)
2007-11-28 19:27 UTC, Jurgen Kramer
no flags Details

Description Jurgen Kramer 2007-11-28 19:12:22 UTC
Description of problem:
With NM I can not get a connection with my AP while using WPA-PSK. When I use
wpa_supplicant from the commandline I do get a connection.

Version-Release number of selected component (if applicable):
wpa_supplicant-0.5.7-16.fc8
NetworkManager-0.7.0-0.5.svn3030.fc8

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
NM tries to get a connection but keeps coming back asking for the WPA-PSK
passphrase.

Expected results:
Get a working connection.

Additional info:

Comment 1 Jurgen Kramer 2007-11-28 19:25:52 UTC
This is on a MacBook with atheros Wifi (AR5006EG 802.11 b/g Wireless PCI Express
Adapter (rev 01) ) and the madwifi driver from SVN (r2990) because the ath5k
driver does not support my card.



Comment 2 Jurgen Kramer 2007-11-28 19:27:17 UTC
Created attachment 271641 [details]
output from NetworkManager --no-daemon

Attached output from starting NetworkManager with --no-daemon. When it asked
for the key again I pressed cancel.

Comment 3 Dan Williams 2007-12-03 15:18:43 UTC
Ah, is it that ath5k doesn't support PCI _express_ cards yet?  Because I just
updated to the latest kernel this weekend on a pci-connected ar5006 laptop and
it magically started working with my AP while earlier kernels from last week
didn't.  Failing that I'll need to get madwifi and go build that and test.

Comment 4 Jurgen Kramer 2007-12-03 19:37:25 UTC
Hmm, I am currently running kernel-2.6.23.1-49.fc8 which is the latest FAIK. But
yes, according to lspic I have a PCI-E ar5006.

Comment 5 Jurgen Kramer 2008-06-27 18:15:52 UTC
I can no longer test this as I no longer have the hardware nor the mentioned
versions of the software.

Comment 6 Dan Williams 2008-10-20 14:46:24 UTC
Ok, testing working with WPA-PSK/WPA2-PSK on F8 with 2.6.26.5-6.fc8, NM svn4022.4, and supplicant 0.5.10-6.fc8 on ipw2200 hardware.


Note You need to log in before you can comment on or make changes to this bug.