Bug 403371 - Anaconda dies on bad SQL database
Summary: Anaconda dies on bad SQL database
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 8
Hardware: ppc64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2007-11-28 19:36 UTC by Gary Thomas
Modified: 2014-01-21 23:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 16:06:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Install failure report (55.00 KB, text/plain)
2007-11-28 19:36 UTC, Gary Thomas
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 403181 None None None Never

Description Gary Thomas 2007-11-28 19:36:32 UTC
Description of problem:
Because of bug 403181, I had to rebuild the repodata on the
releases/8/Fedora/ppc/os tree.  If I include the SQL files,
anaconda dies.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Rebuild the repodata on a ppc32 system (I use a mac-mini):
   Start with a fresh copy of the release tree.  I download this using rsync.
   # cd .../releases/8/Fedora/ppc/os
   # mv repodata{,.BAD}
   # cp repodata.BAD/{Fedora-8-,}comps.xml
   # createrepo -d -g repodata.BAD/comps.xml .
2. Install via NFS on a PlayStation/3
3. dies during dependency checks
  
Actual results:


Expected results:


Additional info:

Install works fine if I leave out the "-d" (still building repodata
on the mac-mini and installing on the PS/3)

Comment 1 Gary Thomas 2007-11-28 19:36:32 UTC
Created attachment 271661 [details]
Install failure report

Comment 2 Jeremy Katz 2007-12-04 22:06:39 UTC
We should catch this exception in yum and pass up a yum exception rather than
requiring callers to know about the details

Comment 3 Seth Vidal 2007-12-06 16:06:35 UTC
This is done in todays check ins from ffesti. closing as upstream


Note You need to log in before you can comment on or make changes to this bug.