Bug 40348 - su hangs with blank root password under 2.4.x (similar to bug 37615)
su hangs with blank root password under 2.4.x (similar to bug 37615)
Status: CLOSED DUPLICATE of bug 37615
Product: Red Hat Linux
Classification: Retired
Component: sh-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-12 08:04 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-12 08:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-12 08:04:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
On RH 7.1 with kernel 2.4.4 and sh-utils sh-utils-2.0-13 with root having 
a blank password, 'su -' hangs, leaving an 'stty erase ?' with stat 'T'.  
strace says "write(2, "incorrect password", 18incorrect password)" even 
though password entry in shadow is BLANK.  Plus, this only happens with 
2.4.x - the stock kernel is fine.  See http://www.chipware.net/strace-
output.txt for complete strace output.  Also, if I give root a password, 
this bug goes away.  If I kill -9 the zombie stty process, the su - is 
unhung and a root prompt appears.

How reproducible:
Always

Steps to Reproduce:
1.  Load redhat 7.1, bare install with gcc/etc utils installed.
2.  Blank root password: root::11454:0:99999:7:::
3.  Compile 2.4.4 kernel, install, boot.
4.  login as nonpriv user, run 'su -'
	

Actual Results:  [chip@pioneer chip]$ su -


Expected Results:  [chip@pioneer chip]$ su -
[root@pioneer /root]#

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-05-14 06:41:36 EDT
Looking at the strace output, this seems to be the same problem as 37615, some 
interoperability issue between glibc and the kernel. Update to the current 
kernel and glibc pacakges.


*** This bug has been marked as a duplicate of 37615 ***

Note You need to log in before you can comment on or make changes to this bug.