This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 40351 - installer crashed halfway thru install
installer crashed halfway thru install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-12 12:39 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 16:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-12 12:39:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; Linux 2.2.14-5.0 i586)

Description of problem:
Following prob logged by anaconda for rh7.1            5/9/01

Traceback (innermost last)

File /var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py line 19 in
run
rc = self.todo.doinstall()

File /var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py line 1852 in 
 doinstall(P, self.intf.messageWindow, pkgTimer))
 
File /var/tmp/anaconda-7.1//usr/lib/anaconda/to.py line 1564 in 
instCallback  fn = self.method.getFilename(h, pkgTimer)

File /var/tmp/anaconda-7.1//usr/lib/anaconda/image.py line 82 in 
getFilename  f = open("/mnt/source/" + key)
IOError [Errno 2] no such file or directory:
'/mnt/source/disk1-i386'


this occured not quite half way thru a new install
did not see the exact package being installed
system configuration
cpu   amdk6-500 
motherboard Gigabyte GA-5AA
ram   384mb
micropolis 4gb ide drive 


How reproducible:
Didn't try


Additional info:
Comment 1 Brent Fox 2001-05-14 12:38:48 EDT
Looks like the cd could be bad.  Do you see any error messages on VC3 or VC4?
Comment 2 Need Real Name 2001-05-16 22:27:28 EDT
05/16/01
update...
tried again last night to install and it worked with no problems. I have been
doing a custom install and picked the same packages and the same partition setup
as last time. The only difference between the two installs is: during the first
install, when anaconda asked for the second cd, I put it in the tray and closed
the drawer but clicked the ok button too soon. I got an error box saying the cd
was not mounted. It gave me back the box to check when I was ready and I clicked
on it, and it seemed to mount it ok. It installed some packages after that
before it stopped.   This time I waited for several seconds before I clicked the
ok button. The cd mounted right away this time. Could there be a problem with
anaconda recovering from an unmounted 2nd cdrom? BTW these cdroms I am using are
ones I got from you guys at Redhat, they are not ones I burned from downloaded
images. I am now going to try upgrading a 7.0 install with these cd's since a
friend at work  tried that and it failed for him. Maybe my cd's will work.

Comment 3 Brent Fox 2001-05-17 16:24:48 EDT
That's strange.  From the initial debug message, it seems clear that the
installer is having trouble reading the cd.  That can mean a couple of different
things...one is that the cd itself is damaged (corrupt, scratched, dirty, etc).
 It can also mean that there is something wrong with the cdrom drive itself.  

I'm not sure if clicking the OK button too quickly causes problems or not.  I'll
have to check that out.
Comment 4 Aaron King 2001-05-21 15:45:00 EDT
Workaround: do minimal installation with only packages found on 1st disk.  Then
install packages by hand.  A real pain, but....
Comment 5 Brent Fox 2001-05-21 16:41:06 EDT
Since the install worked with the same disks on the second attempt, I'm going to
resolve this bug.  However, if you see the behavior reappear, please reopen it.

Note You need to log in before you can comment on or make changes to this bug.