Bug 40353 - ps/2 mouse works during install but not after reboot
ps/2 mouse works during install but not after reboot
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-12 13:54 EDT by wmcdermott
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wmcdermott 2001-05-12 13:54:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Install of 7.1 goes fine.  Mouse works even when testing X display.  After
install and the
system is rebooted, the mouse does is not found.  If line 5 from
/etc/sysconf/mouse is deleted and mouseconfig (4.22) is run, it probes for
the mouse but it can not find it.  This is with a ps/2 mouse and a serial
mouse.

How reproducible:
Always

Steps to Reproduce:
1. remove line 5 from /etc/sysconfig/mouse
2. Start mouseconfig
3.
	

Expected Results:  mouse should work.  Since it does not, X can not start.

Additional info:

Configuration:
DFI 400BX chipset motherboard.  PIII 600. 256 Meg RAM, 2940U2W SCSI
controller. GForce2 MX video card. PS/2 mouse, PS/2 keyboard
Comment 1 wmcdermott 2001-05-12 19:29:35 EDT
I found the soundcard I had (a Crystal 4232 chipset) was grabbing interrupt 12
where the ps/2 mouse has to be.  Removing the sound card allowed the mouse to be
found.  
Comment 2 Minh Phung Nguyen 2001-07-10 12:18:08 EDT
Can someone fix this bug please???? I have that problem too. It always complain 
device busy or not ready. I spent many days trying to work around it. This is 
very annoying. Next time, I will switch to another distribution.
 Cheers, M.
Comment 3 David Lawrence 2001-07-10 12:23:51 EDT
Soundcard drivers are not loaded during the install so that explains why you
mouse probably worked fine during the install process but not afterwards. Can
the sound card be configured to not use irq 12 or is it plug and play?
Comment 4 Brent Fox 2002-10-10 14:15:07 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 5 Red Hat Bugzilla 2006-02-21 13:47:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.