Bug 40363 - kernel panic on booting with rawhide kernel 2.4.3-2.14.10.1
kernel panic on booting with rawhide kernel 2.4.3-2.14.10.1
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-12 15:12 EDT by Dries Verachtert
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-18 13:46:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dries Verachtert 2001-05-12 15:12:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I installed the latest rawhide rpms of the kernel. After a reboot, the
kernel panics during
the booting. I tried several times and also reinstalled the kernel rpm.

How reproducible:
Always

Steps to Reproduce:
1. Download the rawhide 2.4.3-2.14.10.1 kernel rpm
2. reboot

	

Actual Results:  shift-page up didn't work so i don't have the complete
output probably. The following text was visible on the screen after the
panic/crash:
v0 = 0000000000000000   t0 = 0000000000000000   t1 = 0000000000000000
t2 = 0000000000000000   t3 = 0000000000000000   t4 = 0000000000000007
t5 = 0000000000000000   t6 = fffffc0000b242a8   t7 = fffffc0000aa4000
s0 = 0000000000000000   s1 = fffffc0000b24e60   s2 = 0000000000000000
s3 = 0000000000000007   s4 = fffffc0000b24e58   s5 = 0000000000000007
s6 = fffffc0000aa7e60
a0 = 0000000000000007   a1 = 0000000000000000   a2 = 0000000000000001
a3 = 0000000000000001   a4 = 0000000000000000   a5 = 0000000000000000
t8 = 000000000000001f   t9 = fffffc0000a29da8   t10 = 0000000000000006
t11 = 000000000000000a   pv = fffffc00008297e0   at = 0000000000000000
gp = fffffc0000b775d8   sp = fffffc0000aa7e60
code = 47fe070f   or zero, sp, s7
b75e0000   stq ra,0(sp)
b53e0008   stq s0,8(sp)
221f0007   lda a0,7(zero)
00000035   call_pal 53
47e00409   or zero,v0,s0
*b7e20000   stq zero,0(t1)
a4220070   ldq t0,112(t1)
Trace: fffffc000084dcac fffffc000084eca4
fffffc000084ef54 fffffc000084a0a4
fffffc000084a3d4 fffffc0000849890
fffffc000081001c
Kernel panic: Attempted to kill the idle task! 
In idle task - not syncing

Expected Results:  a normal bootup :-)

Additional info:

Because i didn't save the previous rawhide kernel, i compiled a new one.
First a kernel without binfmt for coff and binfmt for x86, so only elf and
misc enabled. (misc as module). That kernel worked but i couldn't run
netscape. I compiled a new one, this time also with the other two binfmt as
modules. After reboot: i got the same panic. Again i compiled a new one
without those two binfmt's and the kernel works.

System: Miata alpha, 500au

Please let me know if you need additional information.
Comment 1 Dries Verachtert 2001-05-18 13:46:20 EDT
I downloaded the latest rpmpackages of rawhide yesterday and upgraded all 
packages. Kernel 2.4.3-5 doesn't panic anymore. This kernel boots without any 
problems. Can this bugreport be closed or is there any need to figure out why 
the previous rawhide kernel didn't work?

Kind regards,
Dries

Note You need to log in before you can comment on or make changes to this bug.