This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 403641 - jpilot cannot view private records on x86_64 platform
jpilot cannot view private records on x86_64 platform
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 18:42 EST by George Avrunin
Modified: 2008-02-02 04:00 EST (History)
0 users

See Also:
Fixed In Version: 0.12.2-17.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-02 04:00:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description George Avrunin 2007-11-28 18:42:42 EST
Description of problem: jpilot cannot show private records


Version-Release number of selected component (if applicable):


How reproducible: every time


Steps to Reproduce:
1. Start jpilot with a database containing private records
2. Click on the "lock" button to view private records
3. jpilot asks for password, but never accepts the password
  
Actual results: jpilot never accepts the PalmOS password and so doesn't allow
the user to view private records.


Expected results: Should accept password and unlock private records


Additional info: The problem seems to be due to a 64-bit bug in pilot-link.  I
asked about this problem on the jpilot list and received a response from Ludovic
Rousseau, who pointed me to the following bug he had recently
filed at pilot-link.org: http://bugs.pilot-link.org/1858

He says that the problem is due to a 64-bit bug in pilot-link, where
pi-md5.h has 
  #define UINT32 unsigned long
which is incorrect on 64-bit systems, and that this prevents jpilot from
computing the right hash to view private records.  He recommends
changing this to 
  #define UINT32 unsigned int
though he notes that this will work on 32- and 64-bit systems but fail
on 16-bit ones. 

I rebuilt the pilot-link and jpilot srpms with this change in the pilot-link
source and jpilot can now view private records on my laptop.  So the fix seems
to work, but I have not tested it extensively.

(This is probably really a bug in pilot-link, but as far as I know it only
manifests itself in jpilot.  Rahul Sundaram on the Fedora list recommended
filing it against jpilot.)
Comment 1 Ivana Varekova 2007-12-10 09:49:17 EST
This is pilot-link problem - there have to be change pilot-link source code - so
reassignning to pilot-link.
Comment 2 Ivana Varekova 2007-12-11 03:46:04 EST
Thanks for the bug report and really detailed description/investigation - the
bug is fixed in pilot-link-0.12.2-11.fc8.
Comment 3 Fedora Update System 2007-12-12 14:59:38 EST
pilot-link-0.12.2-11.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pilot-link'
Comment 4 Fedora Update System 2008-01-11 17:11:10 EST
pilot-link-0.12.2-17.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pilot-link'
Comment 5 Fedora Update System 2008-02-02 04:00:12 EST
pilot-link-0.12.2-17.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.