Bug 403671 - Kernel 2.6.24-0.43.rc3.git1.fc9 hangs during boot during isapnp scan for PnP cards
Kernel 2.6.24-0.43.rc3.git1.fc9 hangs during boot during isapnp scan for PnP ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 18:57 EST by Quentin Armitage
Modified: 2007-12-12 16:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 16:52:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2007-11-28 18:57:17 EST
Description of problem:
kernel 2.6.24-0.43.rc3.git1.fc9 hangs during boot

Version-Release number of selected component (if applicable):
kernel 2.6.24-0.43.rc3.git1.fc9

How reproducible:
Always

Steps to Reproduce:
1.Boot the system
2.
3.
  
Actual results:
Kernel hangs during boot after message:
isipnp: Scanning for PnP cards...

Expected results:
Previous kernel (2.6.24-0.42.rc3.git1.fc9) continues booting after outputting
the following message:
isapnp: No Plug & Play device found

Additional info:
Same problem exists in 2.6.24-0.45-rc3.git1.fc9 downloaded from koji.
Comment #1 of bug 402061 appears to be the same problem (although original
report appears to be a different problem), but is reported against
2.6.24-0.42.rc3.git1.fc9, but this is the latest version that works for me.
Comment 1 Paul Black 2007-11-30 03:42:33 EST
Seeing same on 2.6.24-0.55.rc3.git3.fc9.

2.6.24-0.42.rc3.git1.fc9 is also the last one that works for me.
Comment 2 Tom London 2007-11-30 09:58:54 EST
Seeing same problem with kernel-2.6.24-0.57.rc3.git4.fc9

Last one to boot was 0.42.
Comment 3 Clyde E. Kunkel 2007-11-30 11:01:58 EST
using kernel parm noisapnp shows additional msgs before freeze (hand transcribed):

PCI_hotplug:  PCI Hot Plug PCI Core Version: 0.5
isapnp: ISA Plug & Play Support disabled
Real Time Clock Driver v1.12ac
Linux agpgart interface V0.103
agpgart: Detected an Intel i875 Chipset.
agpgart: AGP aperture is 64M @ 0xf8000000
Serial: 8250/16550 driver $ Revision: 1.90 $ 4 ports, IRQ sharing enabled
(hard freeze at this point)

Last good kernel on this x86 system was 2.6.24-0.42.rc3.git1.fc9.

How do you find changes made after 2.6.24-0.42.rc3.git1.fc9 to try to
troubleshoot??  Thanks
Comment 4 antonio montagnani 2007-11-30 13:08:52 EST
exactly the same here as per Clyde comment
Comment 5 MASAO TAKAHASHI 2007-12-01 01:01:39 EST
I have experienced a same probelm.
But, I think that gcc-4.1.2-34 is broken.
I get back to gcc-4.1.2-33 and generate 2.6.24-0.57.rc3.git4.
Then Booting is complete.
Comment 6 Tom Brinkman 2007-12-01 11:16:46 EST
kernels  43 -> 61 will not boot.  All stop very early at 
Time:    hpet clocksource has been installed

Thinkpad T61 2.4Ghz Duocore.  This sysyem has never needed 
any kernel params
Comment 7 Kyle McMartin 2007-12-01 11:57:03 EST
Could you try booting with "initcall_debug" turned on? It should help us narrow
down which code is problematic.

I assume this is 32-bit? (My t61 is booting fine in x86_64 mode with these kernels.)
Comment 8 Tom London 2007-12-01 12:51:00 EST
I can confirm Masao Takahashi: gcc-4.1.2-34 breaks the i686 kernel packages.

I downloaded 2.6.24-0.61.rc3.git5.fc9.i686, it fails to boot.

I reverted gcc to gcc-4.1.2-33 and built i686 packages. It boots fine.

I'll check BZ for gcc, and if nothing is filed, I'll 'cross file' this.
Comment 9 Tom London 2007-12-01 13:27:52 EST
This seems to be BZ'ed here: https://bugzilla.redhat.com/show_bug.cgi?id=407281
Comment 10 Tom Brinkman 2007-12-02 09:28:49 EST
Comment #7 From Kyle McMartin
  ""initcall_debug" turned on"     How do I do that?

   Yes, it is 32bit rawhide, updated daily since F7.  If it helps the mseg just
before the one I posted (hpet)  states somethin about 3 64bit timers.

   I forgot to mention selinux is disabled.  
Comment 11 Tom Brinkman 2007-12-02 10:24:52 EST
Comment #7 From Kyle McMartin (again)
  There was a new kernel in this mornings updates so I 
SWAG'd an edited grub.conf to

title Fedora (2.6.24-0.62.rc3.git5.fc9)
        root (hd0,1)
        kernel /vmlinuz-2.6.24-0.62.rc3.git5.fc9 ro root=LABEL=/1 initcall_debug
        initrd /initrd-2.6.24-0.62.rc3.git5.fc9.img

   Same failure, but more verbose

initcall 0xc0789b6e: init_pipe_fs+0x0/0x41()<6> Time: hpet clocksource has been
installed
returned 0.

   <hang>   Did I do it right, does this help? 
Comment 12 Josh Boyer 2007-12-03 22:21:22 EST
This kernel boots for me:

kernel-2.6.24-0.66.rc3.git7.fc9
Comment 13 Josh Boyer 2007-12-03 22:24:33 EST
You might have hit bug 407281 here.  See if the above kernel boots for you
Comment 14 Tom Brinkman 2007-12-05 09:52:07 EST
Comment #12, #13 From Josh Boyer
Todays 32bit rawhid update, 2.6.24-0.73.rc4.git1.fc9 boots normally.
Comment 15 Steve 2007-12-05 15:55:09 EST
Seems to fixed in kernel-2.6.24-0.73.rc4.git1.fc9!

Note You need to log in before you can comment on or make changes to this bug.