Bug 4038 - Wrong error msg, booting hosed file system
Wrong error msg, booting hosed file system
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: filesystem (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-14 14:06 EDT by bolotine
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 12:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bolotine 1999-07-14 14:06:38 EDT
I recently got this bad news message trying to boot:

/dev/hda11: UNEXPECTED INCONSISTANCY; RUN fsck MANUALLY
		(i.e. without -a or -p options)

I think it would be a good idea if the message told users to
run	fsck.ext2.
fsck doesn't fix anything. The average newbie, home user
like myself, needs to experiment around to find the answer,
and that is not the best scenario, under the circumstances.

BTW:
  I did manage to fix everything, except for one one file
left in /lost+found.

br-xr-srwT   1  17957   32545   101, 104 Sep 11 1994 #12601
which looks like it goes in /dev. Any idea of where I could
find out what the file name is?

Thanks,
Eric Bolotin
Comment 1 Jeff Johnson 1999-07-15 12:42:59 EDT
You can do
	rpm -V dev
to verify the dev package. However, the permissions are goofy
enough that it is unlikely that you lost+found file is "real" --
it's an inode that was damaged so the file type and mode happen
to be as displayed.

There are too many failure modes of a file system to be handled
with a better error message. The message that is displayed, while
uninformative, is at least constant (i.e. the same as its always
been).

Note You need to log in before you can comment on or make changes to this bug.