Bug 40386 - no ISO8859-2 type1 fonts from xfs font server
no ISO8859-2 type1 fonts from xfs font server
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86-ISO8859-2 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-12 18:26 EDT by Vlado Potisk
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-04 05:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2001-05-12 18:26:15 EDT
From Bugzilla Helper:

Description of problem:
Although xfs is configured to load the latin2 fonts,
i.e. the directory /usr/X11R6/lib/X11/fonts/latin2/Type1
is listed in the 'catalogue' section, fonts
from this directory are not available in X.

I can use fonts from all other directories, but
not the mentioned fonts which I need the most.

How reproducible:
Always

Steps to Reproduce:
1.install ISO8859-2 fonts
2.add /usr/X11R6/lib/X11/fonts/latin2/Type1 to xfs config file
3.restart xfs
	
Actual Results:  ISO8859-2 Type1 fonts unavailable, but all
other fonts are OK.

Expected Results:  Expected to be able to use these fonts as in 6.2

Additional info:

I could not find any related error messages in logfiles.
Package version info:
 XFree86-xfs-4.0.3-5,
 XFree86-ISO8859-2-Type1-fonts-4.0.3-5
Comment 1 Vlado Potisk 2001-05-13 12:53:37 EDT
I did not mention that I'm using a remote X terminal.

There is a workaround: today I installed fonts found
on the RH6.2 installation CD
   XFree86-ISO8859-2-Type1-fonts-1.0-9
and now it works.

Note: this RPM installs fonts into different directory
/usr/share/fonts/..... it is necessary to modify xfs
configuration accordingly.
Comment 2 Need Real Name 2001-06-04 05:43:11 EDT
There is one mistake made by building package, type1 font files
(pfb,afm,pfm) must be plain (ungzipped), otherwise applications
cannot deal with them (what's happened): remove line
  gzip -9 $DSTFONT/Type1/{*.pfb,afm/*.afm,pfm/*.pfm}
and in section %files ISO8859-2-Type1-fonts remove last asterix to
  /usr/X11R6/lib/X11/fonts/latin2/Type1/*.pfb
in XFree86.spec file. A quick fix for original installed package is to issue command:
  gzip -d /usr/X11R6/lib/X11/fonts/latin2/Type1/{,afm,pfm}/*.gz
Distributor can also reconsider if not to add to next distribution
urw fonts with strictly latin2 encoding from
ftp://ftp.suse.cz/pub/suse/czfonts/xfntscl2_1_1_0_src.rpm or
ftp://ftp.linux.cz/pub/linux/redhat-cz/7.1/disks/SRPMS/SRPMS/urw-fonts-ISO8859-2
-1.0-1.src.rpm

They are usefull for ex. in Staroffice because Staroffice can't
use latin2 encoding with original supplied urw fonts package
(which contain beside others all latin2 glyphs).
Comment 3 Mike A. Harris 2002-10-25 23:56:13 EDT
I've tested this on a freshly installed Red Hat Linux system with
all updates freshly applied via up2date.  I'm able to use ISO8859-2
fonts fine here with this clean installation.  Running apps on this
box with display on a remote X server also works, as does the
reverse as well.

Closing bug WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.