Bug 40389 - System locks up due to kernel crash.
System locks up due to kernel crash.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-13 05:15 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-13 05:15:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
After booting my system looks fine (except that sometimes after the X login
screen starts one or two ASCII characters are not displayed right on
console screens being replaced by some unusual character).  Then at some
undetermined point, the system just locks up for no apparent reason.  I've
seen dumps from a kernel crash when I'm in run level 3.  I can find no log
messages that relate directly to the cause.  I have found a message,
"modprobe: Can't find module char-major-145" or "module char-major-81" but
not sure if it's relevant to the problem.

How reproducible:
Couldn't Reproduce


Additional info:
Comment 1 Alan O 2001-05-16 10:39:18 EDT
I have the same problem. System works fine for a while (around 30 hours or so)
and then I get random OOPSes and eventually a kernel panic. But that's not all
:). As I let the system run (even before getting OOPSes) certain things will
stop working, for example xinetd (Yes, I tried re-starting it. Still no worky).
Some system software stops working, too. For example, kill, ps, and top all lock
up the terminal (no CTRL-C out of it).  I'm also getting a  modprobe: Can't
locate module ppp0 . I don't know whether this is related or not.

RedHat 7.1 Upgraded from 7.0. Stock kernel.
Comment 2 Arjan van de Ven 2001-05-16 10:43:28 EDT
Ok; does this go away if you 
rm /etc/cron.d/kmod
and then
service crond restart
?
Comment 3 Need Real Name 2001-05-16 20:32:10 EDT
I think now part of the original problem stemmed from an edit I did to the
/etc/cron.d/kmod file when I changed the 10 minute interval to 30 minutes. 
After I found the kernel crashing, I changed it back and it has crashed only
once since.  But I still have the funky character display problem and the
modprobe errors/warnings.
Comment 4 Hermann Schichl 2001-06-10 04:12:24 EDT
We are experiencing similar problems here.
However, they only seem apparant on computers
using the 8139too network module. They have
disappeared in one computer after changing
the network card to a eepro100.

Note You need to log in before you can comment on or make changes to this bug.