Bug 404281 - xm fails to create domain with pci=xx.yy.z option
xm fails to create domain with pci=xx.yy.z option
Status: CLOSED DUPLICATE of bug 339421
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 06:39 EST by Marc Schiffbauer
Modified: 2009-12-14 16:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 15:54:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Python backtrace from /var/log/xen/xend.log (8.88 KB, text/plain)
2007-11-29 06:39 EST, Marc Schiffbauer
no flags Details
Patch against pciif (1.41 KB, patch)
2007-12-08 09:05 EST, Mark Wormgoor
no flags Details | Diff

  None (edit)
Description Marc Schiffbauer 2007-11-29 06:39:15 EST
Description of problem:
I need to attach some PCI devices (LAN adapter) directly to a domU.
pciback module has been loaded and pci-devices bound to it.

But either putting "pci=['09:00.0','09:00.1']" into the config file nor the
cmdline option "pci=09:00.0" work...

Error Message:
Error: function takes exactly 4 arguments (3 given)

Version-Release number of selected component (if applicable):
xen-3.0.3-41.el5


How reproducible:
always


Steps to Reproduce:
1. create a VM config like this (with default RHEL5 guest installation):
name = "testvm"
uuid = "c2436648-0f2c-80c7-0c19-9ce1e5d5f6d4"
maxmem = 256
memory = 256
vcpus = 1
bootloader = "/usr/bin/pygrub"
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
vfb = [ "type=vnc,vncunused=1,keymap=de" ]
disk = [ "phy:/dev/xen03-domU/fw-ext,xvda,w" ]
vif = [ "mac=00:16:3e:10:e6:85,bridge=xenbr1" ]
pci=['09:00.0','09:00.1']

2. In dom0 try 
~# xm create testvm
or (if pci= setting is not in config)
~# xm create testvm pci=09:00.0 pci=09:00.1

Actual results:
error, the domain can not be started

Expected results:
created domain with pci devices attached directly to it
Comment 1 Marc Schiffbauer 2007-11-29 06:39:15 EST
Created attachment 272841 [details]
Python backtrace from /var/log/xen/xend.log
Comment 2 Mark Wormgoor 2007-12-08 06:49:09 EST
Seems like a duplicate of 379601 .
Comment 3 Mark Wormgoor 2007-12-08 09:05:18 EST
Created attachment 282031 [details]
Patch against pciif

Upstream: http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1053
Comment 4 Bill Burns 2008-04-17 15:54:19 EDT
This patch was applied for bz 339421 (379601 mentioned in comment #2 is marked a
duplicate of that). Closing this a dup.



*** This bug has been marked as a duplicate of 339421 ***

Note You need to log in before you can comment on or make changes to this bug.