Bug 404301 - Package perl-Frontier-RPC-Client 0.07-7 conflicts with perl-Frontier-RPC
Package perl-Frontier-RPC-Client 0.07-7 conflicts with perl-Frontier-RPC
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
510
All Linux
high Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Brandon Perkins
:
Depends On:
Blocks: 248642
  Show dependency treegraph
 
Reported: 2007-11-29 07:06 EST by Jan Pazdziora
Modified: 2008-04-02 16:59 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 16:59:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2007-11-29 07:06:35 EST
Description of problem:

I've built myself ISO today. It contains

# ls -la RPMS/perl-Frontier-RPC-*
-r--r--r--  1 root root 33070 Nov 29 12:48 RPMS/perl-Frontier-RPC-0.07-7.noarch.rpm
-r--r--r--  1 root root 18621 Nov 29 12:47
RPMS/perl-Frontier-RPC-Client-0.07-7.noarch.rpm

When installing the Satellite, the Installing RHN packages. step fails with the
following error in the log:

Package perl-Frontier-RPC-Client  0.07-7 conflicts with perl-Frontier-RPC

Version-Release number of selected component (if applicable):

Satellite 5.1.0 as of November 29, 2007.

How reproducible:

Tried once.

Steps to Reproduce:
1. Get new ISO.
2. Try to install it (or upgrade using it).
  
Actual results:

Installation fails, with error message

Package perl-Frontier-RPC-Client  0.07-7 conflicts with perl-Frontier-RPC

in the log.

Expected results:

No error message.

Additional info:
Comment 1 Jan Pazdziora 2007-11-29 07:07:48 EST
It looks like either these two should not conflict, or only one of them should
be present on the ISO. Assigned to Mirek as he knows what magic he did with that
perl-Frontier-RPC thing.
Comment 2 Miroslav Suchý 2007-11-30 04:14:07 EST
There should be only perl-Frontier-RPC-0.07-7.noarch.rpm. The client should not
be there.
Comment 3 Miroslav Suchý 2007-11-30 04:31:15 EST
OK, I removed -Client package.
/cvs/rhn/rhn/satellite/MANIFEST-4AS,v  <--  MANIFEST-4AS
new revision: 1.74; previous revision: 1.73
Comment 4 Miroslav Suchý 2007-12-13 04:39:15 EST
From release team:
A general feeling was to try and see if we could get this into the RHEL release,
either Extras channel or main distro along with the other perl modules.

Basic argument, nearly all our tools expose and use XML-RPC for API, bugzilla,
RHN, Issue Tracker, and more no doubt, yet, with perl, we do not ship/provide a
way to communicate with them within OS. We get multiple requests from
customers/users of RHN Hosted and Satellite XML-RPC API to justify looking to
supply beyond just Satellite channels.

A minor negative about maybe adding to the RHN Tools channel, is that all
content currently in Tools is RHN/Satellite owned/coded stuff, no 3rd party code
packages within the channel.

So, going to poke RHEL PM, and see what we get back. 

Comment 5 Miroslav Suchý 2007-12-14 07:27:01 EST
Comment #4 has been meant for another bug. Please ignore.
Moving ON_QA.
Comment 6 Brandon Perkins 2007-12-14 11:11:42 EST
Verified.  Satellite currently installs just fine.
Comment 7 wes hayutin 2008-03-19 13:56:08 EDT
Verified.  Satellite currently installs just fine.
Comment 8 Brandon Perkins 2008-04-02 16:59:15 EDT
API call Enhancements for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.