Bug 40449 - XFree86 and SMP
Summary: XFree86 and SMP
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-13 22:01 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 08:34:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log (25.30 KB, text/plain)
2001-05-17 23:16 UTC, Need Real Name
no flags Details
messages (293.11 KB, patch)
2001-05-17 23:18 UTC, Need Real Name
no flags Details | Diff
XF86Config-4 (1.93 KB, patch)
2001-05-17 23:18 UTC, Need Real Name
no flags Details | Diff

Description Need Real Name 2001-05-13 22:01:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)

Description of problem:
When I use an SMP enabled kernel X starts then hangs just after loading 
the desktop. I have tried recompiling the kernel, taking out the PCI cards 
and swapped the Matrox G400 for a Riva TNT2, all with the same result.

How reproducible:
Always

Steps to Reproduce:
1. Boot the SMP Kernel (either 2.4.2 as provided or 2.4.4 as downloaded)
2. startx
3. wait for a few secs then hangs.
	

Actual Results:  Shows the tips then hangs

Additional info:

Seems to happen faster in GNOME than KDE. Note that the uni-processor 
kernel is stable and X works fine. 

Hardware :
MSI 694D Pro (promise cont. but no raid). 256MB ram. Matrox G400, Fire-
wire OHCI card, TV card, USB mouse, PS2 keyboard, IBM harddisk, PCI Modem.

Software:
Tried Mandrake 8 && RH 7.1

Comment 1 Mike A. Harris 2001-05-15 04:33:47 UTC
If you boot into graphical mode, I need you to boot into runlevel 3
instead, startx, wait until the problem occurs, reboot again into runlevel3
without any X, then attach using the link below:

/etc/X11/XF86Config-4
/var/log/XFree86.0.log
/var/log/messages
You may want to remove any private info from the messages file first.

Comment 2 Need Real Name 2001-05-17 23:16:25 UTC
Created attachment 18830 [details]
XFree86.0.log

Comment 3 Need Real Name 2001-05-17 23:18:01 UTC
Created attachment 18831 [details]
messages

Comment 4 Need Real Name 2001-05-17 23:18:38 UTC
Created attachment 18832 [details]
XF86Config-4

Comment 5 Mike A. Harris 2001-07-26 19:51:42 UTC
Does this occur when using the Red Hat supplied SMP kernel? (binary, not
a rebuild).

What specific Red Hat kernel are you using that is having this
problem? (again, provided binary, not rebuilt)

Comment 6 Need Real Name 2001-07-27 09:59:31 UTC
I have indeed tried with the default kernel.

The kernel is redhat 7.1 (2.4.2-smp) although this is a little unstable due to 
the promise controller! (get kernel oops when booting).

As I said the system works fine when running the single processor kernel. I am 
not sure that this is a kernel problem though.

Comment 7 Mike A. Harris 2001-11-06 14:27:47 UTC
Make sure you are running the latest flash rom update from your
motherboard manufacturer.  Also, check the various CMOS settings
and insure they are correct.  This problem is almost certainly
hardware specific so I suspect the motherboard and/or BIOS in
combination with the video hardware.

By the way, your log file seems to show an IRQ conflict between
3 devices.  This may very well cause problems.  Also, make
sure the video hardware is assigned an IRQ in the CMOS.

Try disabling DRI also.

If all else fails, I recommend upgrading to Red Hat Linux 7.2 or
at least upgrading to XFree86 4.1.0-3 and the latest erratum
kernel for 7.2 as well as all their dependacies.  It is possible
this may solve the problem if the above does not, and the 7.2
packages, or something based on them is likely to be released
as erratum for 7.1 soon, so it would be good to test as 4.1.0
will be with us for quite a while.

Comment 8 Mike A. Harris 2002-01-25 08:33:57 UTC
XFree86 4.1.0-15 has been released for Red Hat Linux, as has a new kernel.
While I believe your problem to be a hardware issue, you should upgrade
to our latest packages just in case it solves the problem for you.

If you continue to have this problem please provide updated info and new
file attachments.

Comment 9 Mike A. Harris 2002-02-09 08:08:08 UTC
Assuming the problem is fixed now.  Please reopen bug report with updated
info after updating all released Red Hat Linux erratum if the problem
persists.  Please attach new X server log and kernel messages file at
that time if needed also.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.