Bug 40452 - ksysctrl damages file systems when refreshing data
Summary: ksysctrl damages file systems when refreshing data
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 40451 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-13 22:42 UTC by Matthias Kruspe
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-19 15:21:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Kruspe 2001-05-13 22:42:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
When I use the program ksysctrl and click at the Refresh button, the hard
disc activity raises very heavy. After that I get various messages about
damaged file systems. Can't reboot the system normally. Must do a hard
reset. After that i get kernel panics and cant mount the filesystems. The
partition table and a ms-windows-system at the same disc are also affected.
Maybe there is a bug in the scsi-interface. (I only use SCSI, no IDE)

How reproducible:
Always

Steps to Reproduce:
1.start ksysctrl
2.click refresh
3.
	

Actual Results:  heavy damage to the filesystem

Expected Results:  re-scanning the scsi-chain and refreshing the data shown

Additional info:

Comment 1 Matthias Kruspe 2001-05-13 22:43:44 UTC
*** Bug 40451 has been marked as a duplicate of this bug. ***

Comment 2 Bernhard Rosenkraenzer 2001-05-14 10:33:51 UTC
Looking at the ksysctrl code, I don't see any write accesses to the 
filesystem. Also, I can't reproduce this on my (IDE-only) system.

This must be a problem with SCSI (most likely with the low level driver for 
your controller; which controller are you using?) or with your hardware.

Assigning to kernel because that's where SCSI drivers reside.



Comment 3 Bernhard Rosenkraenzer 2001-05-14 10:36:27 UTC
Switching to NEEDINFO, please add which controller you're using.


Comment 4 Matthias Kruspe 2001-05-14 12:39:04 UTC
I am using the Adaptec AHA2940UW-Controler. The problem occures with the
original Red-Hat 7.1 Kernel from the Installation-CD. 
Harddisk is a IBM DDRS (SCSI-0)
CD-ROM is a PLEXTOR ULTRA-PLEX
ZIP Drive 100
(everything is SCSI)


Comment 5 Matthias Kruspe 2001-05-14 12:41:18 UTC
Maybe the type of the mainboard is interesting too.
It is a ASUS P2B (intel 440BX chipset)


Comment 6 Michael K. Johnson 2002-01-18 21:11:39 UTC
I don't see what is happening here, but I'll ask the obvious question:
have you tried upgrading to our errata kernel?

Comment 7 Matthias Kruspe 2002-01-19 15:21:09 UTC
I have upgraded. But I don't know whether it fixed the problem. I don't want to 
try it out again and risk my system.



Note You need to log in before you can comment on or make changes to this bug.