Bug 404601 - anaconda crashes on 'cdrom' line in kickstart
anaconda crashes on 'cdrom' line in kickstart
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 10:21 EST by Jan Safranek
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 10:26:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stack trace screenshot (24.04 KB, image/png)
2007-11-29 10:21 EST, Jan Safranek
no flags Details

  None (edit)
Description Jan Safranek 2007-11-29 10:21:47 EST
Description of problem:

I have following two-line kickstart file:
install
cdrom

When I start installation of F8 in qemu-kvm (but that's IMHO irrelevant) with
command line "linux ks=nfs:my_hostname:/home/honza/test.ks" and fedora i386 DVD
in /dev/hdd , anaconda asks for language and keyboard layout, starts X11 and
then immediately crashes back to text mode with attached stack trace (the
garbage is caused by VNC, the text should be readable though).

If I omit the 'cdrom' line, anaconda asks for installation method and then
continues without any error (i.e. my installation DVD is OK and I can install
from it).
Comment 1 Jan Safranek 2007-11-29 10:21:47 EST
Created attachment 272981 [details]
stack trace screenshot
Comment 2 Chris Lumens 2007-11-29 10:26:13 EST
This is fixed in a later version of pykickstart.

Note You need to log in before you can comment on or make changes to this bug.