Bug 404791 - Flash Player Causes Firefox to Crash on Some Sites
Flash Player Causes Firefox to Crash on Some Sites
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libflashsupport (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
http://http://www.huffingtonpost.com/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 13:17 EST by David Hart
Modified: 2008-06-30 16:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-30 16:09:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hart 2007-11-29 13:17:53 EST
Description of problem:


The subject URL crashes Firefox 2.0.0.9 causes FF to exit when the play button
is clicked. This has occurred with other sites as well but not all embedded
flash media.


Workaround:

Replacing FF with the pre-compiled Mozilla distributed version corrects the
problem. I also re-spun the RPM with 2.0.0.10 source code (which requires
changing two of the patches). Using this RE-introduces the issue.
Comment 1 David Hart 2007-11-29 13:54:45 EST
Scratch that. Using the mozilla tarball only fixed one site. Removing
libflashsupport stops the crash BUT now I have no sound.

This was never a problem previously (FC7)
Comment 2 Matěj Cepl 2007-11-30 04:17:30 EST
OK, pushing to correct component.
Comment 3 Jens Lautenbacher 2007-12-04 11:53:03 EST
Why is this severity "Low"? As flash video is very common these days and the
difference between the stability with Fedora 7 vs. 8 is huge,  these videos
(e.g. on spiegel-online.de, but also elsewhere) continue to crash gecko in an
alarming rate. The OP ist right in that there are sites more error prone than
others, but even the "better" sites will make gecko crash sometimes.
Comment 4 David Hart 2007-12-04 16:54:39 EST
It's a pulse audio problem and a simple work-around. 

rpm -e alsa-plugins-pulseaudio libflashsupport kde-settings-pulseaudio

I find that I am getting better audio without pulse. With pulse, I experienced a
delay on playing system notifications (which might be more pronounced with KDE
than Gnome or XFCE).
Comment 5 Jens Lautenbacher 2007-12-04 18:05:32 EST
I assume that uninstalling pulseaudio will not restore the previous dmix
functionality out of the box... so it isn't a viable solution for the "normal"
user.  

As pulse seems to be going to be the desktop linux audio standard, I would
rather prefer having those bugs fixed instead of just removing it... 
Comment 6 Dan O'Brien 2008-06-30 09:15:04 EDT
install nspluginwrapper and ff will stop crashing.  flash may go grey from time
to time, just reload the page.
Comment 7 Matěj Cepl 2008-06-30 16:09:38 EDT
My mistake, should have asked about nspluginwrapper myself. I am sorry.

Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.