Bug 404921 - RFE: protect rpm managed repository definitions from removal and edit
RFE: protect rpm managed repository definitions from removal and edit
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 14:56 EST by Jef Spaleta
Modified: 2007-12-31 09:52 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3.28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 09:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2007-11-29 14:56:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc8 Firefox/2.0.0.9

Description of problem:
The remove repository feature in the repository manager makes its
exceedingly easy to remove or break repository definitions which are installed
via package files such as those installed by the fedora-release package.  Casual removal of these definitions results in severe problems and leaves users extremely confused as to how to re-equip repository definitions.

It will seldom be in the best interest of the user to prefer to remove such definitions over just disabling them. However the layout of pirut UI stresses the removal option, and de-emphasizes the enable/disable checkbox.

What I would like to see is some way to protect rpm managed repository definitions from unwarranted editting or removal.  Perhaps have pirut probe to see if a definition is rpm managed and if so, then to produce an additional
'do you want to continue dialog' with text similar to this:
"The 'foo' repository definition is managed as part of the 'foo-release' package installed on your system.  Removal/Editting of this repository definition will most likely interfere with updating the 'foo-release' package in the future.  Please consider disabling this repository in pirut instead of removing/editting."

with a dialog button bar like:  [Disable] [Remove/Edit] [Cancel]


I'd also like to see the enable/disable check box with the stronger emphasis, but I'm not a ui designer so I've no mature suggestions on how to actually do this sanely.    

The remove button is the repository equivalent to a self-destruct button.  If you're gonna make it bigger and shinier than the more mundane and safer power-off button (disable) for god sake's man at least put it underneath the software ui equivalent of the glass box like they have on Deal or No Deal.
or the equivalent to one of those cool switch guards Jack Bauer has to use when he's arming explosives like:  http://www.newark.com/jsp/Electromechanical+&+Industrial+Control/Switch+Components/HONEYWELL+S&+C/19PA184-NT/displayProduct.jsp?sku=39B5427

-jef"going through 24 withdraws due to the writer's strike"spaleta

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:




Actual Results:


Expected Results:


Additional info:
Comment 1 Jeremy Katz 2007-11-30 17:43:47 EST
Fixed in 1.3.28.  Building for rawhide now, will push to -updates next week
Comment 2 Jeremy Katz 2007-12-31 09:52:00 EST
New versions of pirut have been released that should address these issues

Note You need to log in before you can comment on or make changes to this bug.