Bug 404931 - No such file or directory from valid mount point
No such file or directory from valid mount point
Status: CLOSED DUPLICATE of bug 371341
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 15:00 EST by Jack Neely
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 20:39:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog from autofs (4.41 KB, text/plain)
2007-11-29 15:02 EST, Jack Neely
no flags Details

  None (edit)
Description Jack Neely 2007-11-29 15:00:58 EST
Description of problem:
I'm using autofs to bind mount directories from AFS to mount points under /ncsu.
 When autofs first mounts a mount point the command that triggers it returns No
such file or directory but the mount is mounted correctly.

$ ls /ncsu/sfcallic
ls: /ncsu/sfcallic: No such file or directory
$ ls /ncsu
sfcallic
$ ls /ncsu/sfcallic
<directory listing>

I have the following map defined:

/ncsu  ldap://ldap.ncsu.edu/nisMapName=auto_ncsu,ou=mounts,dc=ncsu,dc=edu
--timeout=180 --debug

This mostly affects a script that is used to os.stat() a directory under /ncsu
to verify it is a valid "locker" and then run a .environment script in that
locker to set up the environment for the contained application.

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.55

How reproducible:
Oddly.  It seems to most frequently happen at the console of the machine in
question.  Less so if you are ssh'd into the machine.
Comment 1 Jack Neely 2007-11-29 15:02:27 EST
Created attachment 273221 [details]
syslog from autofs

This contains some logs from autofs with --debug.  I don't see a specific
problem it says its able to mount the directory and this was from an instance
where ls /ncsu/sfcallic returned no such file or directory.
Comment 2 Jack Neely 2007-11-29 15:09:33 EST
This doesn't seem to affect root, just normal users.

I can confirm the behavior with autofs-5.0.1-0.rc2.42.i386.rpm,
autofs-5.0.1-0.rc2.55.i386.rpm, and autofs-5.0.1-0.rc2.43.0.2.i386.rpm

Comment 3 Ian Kent 2007-11-29 20:39:32 EST

*** This bug has been marked as a duplicate of 371341 ***

Note You need to log in before you can comment on or make changes to this bug.