Bug 405021 - scsi_id fails to show version info and proper wwids for multipath
scsi_id fails to show version info and proper wwids for multipath
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev (Show other bugs)
5.0
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2007-11-29 15:39 EST by Dave Berry
Modified: 2014-09-15 20:18 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:18:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Berry 2007-11-29 15:39:45 EST
Description of problem:
multipath does not work due to a failure of scsi_id.   When /sbin/scsi_id is run
with -V(version) nothing is returned.  Also when /sbin/scsi_id -u -g -s
/block/sdq is run the wwid returned is longer than the wwid in RHEL 4.  This
prohibits multipath to set wwid in /etc/multipath.conf since the port of the SAN
is returned in the longer wwid.


Version-Release number of selected component (if applicable):

udev-095-14.5
device-mapper-multipath-0.4.7-8

How reproducible:

very reporducible


Steps to Reproduce:
1.run /sbin/scsi_id -V
2.run /sbin/scsi_id -u -g -s /block/<device>
3.
  
Actual results:
nothing is returned for step 1
the long wwid is returned for step 2

Expected results:

-V should yield version numbers
the wwid should be limited to just the drive ID and not include the port on the SAN



Additional info:
Comment 1 Ben Marzinski 2007-12-11 13:35:15 EST
These are both scsi_id problems, not device-mapper-multipath problems. I'm
switching the component to udev, which provides /sbin/scsi_id.
Comment 4 Harald Hoyer 2014-01-31 07:31:54 EST
commit 11678eff6a40b05d192be65146a66d5e1e8252ec
Comment 6 Harald Hoyer 2014-05-06 10:32:10 EDT
# scsi_id -V
scsi_id version: 0.9

'-x' now adds a
ID_SERIAL_SHORT=
environment variable, which is most likely what you want.
Comment 10 errata-xmlrpc 2014-09-15 20:18:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1239.html

Note You need to log in before you can comment on or make changes to this bug.