Bug 405031 - Recording Fails On RHEL5.1 and ADI 1984 Codec
Recording Fails On RHEL5.1 and ADI 1984 Codec
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
low Severity high
: ---
: ---
Assigned To: Brian Maly
Red Hat Kernel QE team
:
Depends On:
Blocks: 499437
  Show dependency treegraph
 
Reported: 2007-11-29 15:45 EST by Rogelio Noriega
Modified: 2010-10-22 16:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 483594
Environment:
Last Closed: 2009-05-13 14:59:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Soundcard detection logs (47.57 KB, application/octet-stream)
2007-11-29 15:48 EST, Rogelio Noriega
no flags Details
scsrun.log (1.23 KB, application/octet-stream)
2007-11-29 15:49 EST, Rogelio Noriega
no flags Details
amixer output from alsamixer configuration that allowed for some audio (3.34 KB, text/plain)
2008-02-07 16:11 EST, John Feeney
no flags Details
amixer output from alsamixer configuration that allowed for some audio (3.34 KB, text/plain)
2008-02-07 16:15 EST, John Feeney
no flags Details

  None (edit)
Description Rogelio Noriega 2007-11-29 15:45:19 EST
Description of problem:
Recording fails on RHEL5.1 and ADI 1984 Codec. On Dell PWS T3400 

Version-Release number of selected component (if applicable):
Alsa Driver Kernel 2.6.18-53

How reproducible:
100%

Steps to Reproduce:
1.Install RHEL5.1
2.Attempted to record using an anolog mocrophone.
3.
  
Actual results:
No sound from created wav file


Expected results:
Recorded file play back


Additional info:
Comment 1 Rogelio Noriega 2007-11-29 15:48:27 EST
Created attachment 273311 [details]
Soundcard detection logs
Comment 2 Rogelio Noriega 2007-11-29 15:49:14 EST
Created attachment 273321 [details]
scsrun.log
Comment 3 Brian Maly 2007-12-13 20:12:08 EST
Is 'arecord' being used to record?

Is the mic level turned up in alsamixer? 

External or internal microphone? If external, is it a mono mic or stereo?

When you play back the sound file, do you get white noise or no sound at all?
Comment 4 John Feeney 2007-12-18 14:54:07 EST
Rogelio,
Can you provide some insight into Brian's questions?
Thanks so much.
  John
Comment 5 Rogelio Noriega 2007-12-21 15:10:45 EST
1. I'm using arecord
2. Yes mic is enabled and turned up.
3. I'm using a external mic mono.
4. Playback no sound at all
Comment 6 Brian Maly 2007-12-21 15:21:26 EST
Is this configured to use a mono mic? Can you attach a "amixer" output to this Bug?


Thanks for the feedback. Its possible we need an ALSA quirk to get things
working right. Since quirks are model specific, can you provide the make and
model of the affected hardware? Thanks.
Comment 7 Brian Maly 2007-12-21 15:22:31 EST
Sorry, just noticed we have an amixer output already attached to this Bug.
Comment 8 Larry Troan 2008-01-03 16:10:25 EST
Flipping back to ASSIGNED per comment #7.
Comment 9 Rogelio Noriega 2008-01-03 18:50:08 EST
reply to comment #6 the systems affected are Dell Precision Workstations 
T3400, T5400, and T7400. 
Comment 10 Rogelio Noriega 2008-01-17 12:47:09 EST
Update: Systems affected are T5400, and T7400 not T3400. On the T3400 pressing
F5 displays 2 additional capture devices if these are enabled recording works.
This does not resolve the issue on the T5400, and T7400.
Comment 11 John Feeney 2008-01-22 10:42:58 EST
Rogelio,
It would appear as though this is a relatively new codec and so we need more
info about it. Can we get the wiring and configuration from the vendor? A patch
would be nice. 
Comment 12 John Feeney 2008-02-07 16:11:44 EST
Created attachment 294270 [details]
amixer output from alsamixer configuration that allowed for some audio
Comment 13 John Feeney 2008-02-07 16:15:16 EST
Created attachment 294271 [details]
amixer output from alsamixer configuration that allowed for some audio
Comment 14 John Feeney 2008-02-07 16:23:30 EST
A little update:

Added one file (but got two comments #12 & #13, not sure why) that has 
amixer output from the alsamixer configuration used when I got audio 
output from a rear jack and recorded via a rear jack but got no output 
or input from the jacks on the front. 

The rear jacks are labeled speakers so I am confused. But the right 
rear speaker jack can be used to record and the left speaker can be used 
to hear via the headphones. This was done on the T5400 that Dell sent.
Comment 15 Jaroslav Kysela 2008-02-21 11:00:58 EST
According provided schematics, rear Green jack is Line Out and rear Blue jack is
Mic / Line in.

Unfortunately, the problem with front jacks is not clear. ALSA should support
this configuration by default. FP OUT jack (not sure which one is out) should be
enabled using Headphone switch in alsamixer. FP IN (MIC) jack should be enabled
using 'Mic' in 'Input Source'.
Comment 16 Rogelio Noriega 2008-03-04 16:21:04 EST
Playback and record worked on RHEL5 Gold with the following alsa rpm. 

alsa rpm: 
http://support.dell.com/support/topics/global.aspx/support/downloads/en/downloa
ds_splash?c=us&cs=555&l=en&s=biz&~mode=popup&file=237130

dkms rpm: 
http://support.dell.com/support/topics/global.aspx/support/downloads/en/downloa
ds_splash?c=us&cs=555&l=en&s=biz&~mode=popup&file=213661
Comment 17 Rogelio Noriega 2008-05-06 15:59:17 EDT
Record and the front jacks are working with RHEL5.2 Snapshot 6. I've verified 
this on the T5400 and T7400 I still need to do a little more testing but it's 
looking good. I also have to verify it didn't break anything on the T3400 
which was working.
Comment 18 Rogelio Noriega 2008-05-06 18:11:05 EDT
Recording and the front jacks are still working in RHEL 5.2 Snapshot 7.
Comment 19 RHEL Product and Program Management 2008-07-25 13:07:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 20 Ludek Smid 2008-07-25 17:54:42 EDT
Unfortunately the previous automated notification about the
non-inclusion of this request in Red Hat Enterprise Linux 5.3 used
the wrong text template. It should have read: this request has been
reviewed by Product Management and is not planned for inclusion
in the current minor release of Red Hat Enterprise Linux.

If you would like this request to be reviewed for the next minor
release, ask your support representative to set the next rhel-x.y
flag to "?" or raise an exception.
Comment 21 Brian Maly 2008-08-06 22:35:39 EDT
ALSA was updated in 5.2 and this issue may now be resolved. Can we test a RHEL5.2 kernel and see if this is resolved?
Comment 23 RHEL Product and Program Management 2009-02-16 10:42:57 EST
Updating PM score.
Comment 24 Brian Maly 2009-02-17 15:18:00 EST
Can we close this bug (per Comment #18)? I presume this to mean things now work OK.
Comment 26 RHEL Product and Program Management 2009-04-23 13:49:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 27 Rogelio Noriega 2009-04-24 11:09:28 EDT
Resolved this issue can be closed.
Comment 28 John Feeney 2009-05-13 14:59:53 EDT
Dell says close, so I will. (Thanks, Roger.)

Note You need to log in before you can comment on or make changes to this bug.