Bug 405281 - SELinux is preventing /sbin/setfiles (named_conf_t) "associate" to <Unknown> (proc_t).
SELinux is preventing /sbin/setfiles (named_conf_t) "associate" to <Unknown> ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 407291 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 20:06 EST by Dave
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 9.5.0-20.b1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 10:25:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave 2007-11-29 20:06:14 EST
Summary
    SELinux is preventing /sbin/setfiles (named_conf_t) "associate" to <Unknown>
    (proc_t).

Detailed Description
    SELinux denied access requested by /sbin/setfiles. It is not expected that
    this access is required by /sbin/setfiles and this access may signal an
    intrusion attempt. It is also possible that the specific version or
    configuration of the application is causing it to require additional access.

Allowing Access
    You can generate a local policy module to allow this access - see
    http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385 Or you can disable
    SELinux protection altogether. Disabling SELinux protection is not
    recommended. Please file a http://bugzilla.redhat.com/bugzilla/enter_bug.cgi
    against this package.

Additional Information        

Source Context                system_u:object_r:named_conf_t:s0
Target Context                system_u:object_r:proc_t:s0
Target Objects                None [ filesystem ]
Affected RPM Packages         policycoreutils-2.0.31-15.fc8 [application]
Policy RPM                    selinux-policy-3.0.8-56.fc8
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   plugins.catchall
Host Name                     home.supercaregistry.info
Platform                      Linux home.supercaregistry.info 2.6.23.1-42.fc8 #1
                              SMP Tue Oct 30 13:55:12 EDT 2007 i686 i686
Alert Count                   633
First Seen                    Thu 29 Nov 2007 05:18:28 PM MST
Last Seen                     Thu 29 Nov 2007 05:18:35 PM MST
Local ID                      26da9801-7a4b-4211-99e2-cc8e0d43b677
Line Numbers                  

Raw Audit Messages            

avc: denied { associate } for comm=restorecon dev=proc egid=0 euid=0
exe=/sbin/setfiles exit=-13 fsgid=0 fsuid=0 gid=0 items=0 name=sys pid=11247
scontext=system_u:object_r:named_conf_t:s0 sgid=0
subj=system_u:system_r:setfiles_t:s0 suid=0 tclass=filesystem
tcontext=system_u:object_r:proc_t:s0 tty=(none) uid=0
Comment 1 Adam Tkac 2007-12-03 02:47:33 EST
*** Bug 407291 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2007-12-05 07:18:27 EST
Fix is commited but I'm waiting to 9.5.0b1 with final build. Thanks for your report.
Comment 3 Fedora Update System 2007-12-07 16:30:15 EST
bind-9.5.0-19.b1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'
Comment 4 Fedora Update System 2007-12-20 14:49:12 EST
bind-9.5.0-20.b1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.