Bug 405411 - Plotting problems in octave
Plotting problems in octave
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnuplot (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 00:41 EST by Fred Bacon
Modified: 2008-02-13 00:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.0.0-19.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 00:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to gnuplot.spec to enable the wxt terminal (687 bytes, patch)
2007-11-30 10:11 EST, Quentin Spencer
no flags Details | Diff

  None (edit)
Description Fred Bacon 2007-11-30 00:41:54 EST
Description of problem:
There seems to be serious problems with octave's plotting capabilities.  Plots
are made with gnuplot, so it's difficult to know which program is at fault, but
it looks as though sometimes garbage is being sent to gnuplot.  

Version-Release number of selected component (if applicable):
octave-2.9.15-2.fc8
gnuplot-4.2.0-7.fc8

How reproducible:
The problems are quite easily triggered.

Steps to Reproduce:
1. Start octave and give the following set of commands
2. r = pi * rand(2000,1);
3. hist(r,50)
  
Actual results:
Only some of the histogram is plotted and you are likely to get errors beginning
with something like:

  line 34336: warning: Skipping unreadable file "-��1�"

and/or many lines such as

gnuplot> e
         ^
         line 398: invalid command


gnuplot> 2.07050171829031 0
         ^
         line 398: invalid command


gnuplot> 2.07050171829031 52
         ^
         line 398: invalid command


Expected results:
A histogram of the data using 60 bins should be plotted.

Additional info:
Comment 1 Quentin Spencer 2007-11-30 10:11:05 EST
Created attachment 273921 [details]
Patch to gnuplot.spec to enable the wxt terminal
Comment 2 Quentin Spencer 2007-11-30 10:15:31 EST
This is occuring because the wxt terminal is not currently enabled in the Fedora
release of gnuplot. The feature has been in gnuplot since release 4.2.0, and
recent versions of octave assume it is present if gnuplot is newer than that
release. The wxt terminal can be enabled by simply requiring the build to depend
on wxGTK, as in the patch to the gnuplot.spec file I attached. I have verified
that after recompiling with this option, plotting works again in octave, so I'm
reassigning this as a gnuplot bug.
Comment 3 Quentin Spencer 2007-11-30 15:45:51 EST
OK, after further investigation, it turns out that the lack of wxt terminal was
not at fault--rather I had some customizations on my computer that were causing
similar errors. In fact, it appears that this is a bug in the 4.2.0 release of
gnuplot, which I have verified is fixed in the 4.2.2 release currently available
in the development branch. So, this bug can be closed by pushing the 4.2.2
release to Fedora 8, but I would still like to see the wxt terminal enabled.
Comment 4 Ivana Varekova 2007-12-10 09:24:02 EST
Thanks for bug report and excellent and fast investigation, this problem is
fixed in gnuplot-4.2.2-1.fc8. 
Comment 5 Fedora Update System 2007-12-10 15:48:21 EST
gnuplot-4.2.2-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnuplot'
Comment 6 Fred Bacon 2007-12-12 11:01:15 EST
I've installed the new version of gnuplot from the updates-testing repository. 
The failure when plotting the histogram is gone, but plotting in general is
still seriously messed up when histograms are involved, as the following set of
commands will show.  

 r = 2*pi * rand(2000,1);
 plot(r)
 plot(r.^2)
 hist(r,30)

This may require an update of octave to 2.9.19 as well as the gnuplot update.

I'll try and upgrade octave on my own this evening to see if it helps.  I'll
report back what I find.
Comment 7 Fedora Update System 2008-01-27 02:12:35 EST
gnuplot-4.2.2-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Alex Lancaster 2008-01-28 01:14:39 EST
Can you possibly push an update to F-7 too?
Comment 9 Fedora Update System 2008-01-28 08:41:58 EST
gnuplot-4.0.0-19.fc7 has been submitted as an update for Fedora 7
Comment 10 Fedora Update System 2008-01-29 00:12:57 EST
gnuplot-4.0.0-19.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnuplot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1123
Comment 11 Fedora Update System 2008-02-13 00:12:53 EST
gnuplot-4.0.0-19.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.