Bug 40552 - Run-time configuration of Aironet 4800 not implemented
Run-time configuration of Aironet 4800 not implemented
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 10:11 EDT by Aleksey Nogin
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 15:10:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2001-05-14 10:11:12 EDT
RedHat 6.2 used airo_cs driver for Aironet 4800 cards. That driver
supported run-time configuration and monitoring through the /proc/aironet
directory.

RedHat 7.1 uses aironet4500_cs driver for the same cards. This driver does
not seem to put anything useful in /proc and does work with wireless-tools
(iwconfig says "no wireless extensions").

Is there a reason why RH7.1 uses aironet4500 instead of airo?
Comment 1 Arjan van de Ven 2001-05-14 10:15:36 EDT
The aironet4500_cs is the one that comes with the offical linux kernel tree.
However, we've included the airo_cs as backup driver in our kernel so you 
_can_ use it just fine. All you need to do is change /etc/pcmcia/config

I must say that I'm considering making the airo_cs the default for 4800, the
aironet4500_cs doesn't seem to work well with them. 

Could you try the other driver? If it works I'll change the default for newer
versions of the pcmcia packages.
Comment 2 Aleksey Nogin 2001-05-15 15:10:47 EDT
I tried airo_cs, seems to be working fine.
Comment 3 Arjan van de Ven 2001-05-15 15:15:09 EDT
Thanks for confirming this; I've modified the driver for the next
kernel-pcmcia-cs package we will build. I'm closing this as "fixed in rawhide"
as that is the closest thing to the truth.

Note You need to log in before you can comment on or make changes to this bug.