Bug 40554 - Dell CPx docking station and X
Dell CPx docking station and X
Status: CLOSED DUPLICATE of bug 40109
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 10:57 EDT by Martin C. Messer
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 10:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin C. Messer 2001-05-14 10:57:58 EDT
Description of Problem:

Under 7, the Dell CPx laptop could be configured to use the Generic LCD
1024x768 monitor which would work standalone and with the Dell docking
station. I did a network upgrade using the docking station, and anaconda
worked flawlessly with the external monitor (Dell UltraScan P991), but
after reboot the docking station/monitor combination no longer worked.

This is stock 7.1 using XFree86-4.0.3-5.

The CPx uses this video chip:

class: VIDEO
bus: PCI
detached: 0
driver: Card:ATI Rage Mobility
desc: "ATI|Rage Mobility P/M AGP 2x"
vendorId: 1002
deviceId: 4c4d
subVendorId: 1028
subDeviceId: 00bb
pciType: 1

How Reproducible:

Always

Steps to Reproduce:
1.  W/o an external monitor, use Xconfigurator to configure the video
settings
2.  Shutdown, place laptop in docking station w/ external P991
3.  Startup in an X runlevel.

Actual Results:

X and gdm attempt to start, but instead the screen flashes 4-5 times, waits
a few seconds, and then attempts to respawn X/gdm again, w/o success.

Expected Results:

I should be able to use the same X settings standalone and with the
external monitor and docking station.


Additional Information:
	
This does work with version 7 and XFree86-4.0.1-1.
Comment 1 Mike A. Harris 2001-05-15 00:42:34 EDT
Same problem that others have been reporting.  We supposedly fixed
this I thought prior to our final release of Seawolf.  Maybe not..

*** This bug has been marked as a duplicate of 40109 ***

Note You need to log in before you can comment on or make changes to this bug.