Bug 40557 - ATI Radeon PCI and RH 7.1
ATI Radeon PCI and RH 7.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 11:11 EDT by Rogelio Noriega
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 12:13:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yes, Dri is enabled in XFree Config. Plese see the enclosed /etc/X11/XF86Config-4 file. (1.83 KB, text/plain)
2001-05-14 12:13 EDT, Yu-Pa Ng
no flags Details

  None (edit)
Description Rogelio Noriega 2001-05-14 11:11:54 EDT
Description of Problem:
After running "Xconfigurator" for ATI Radeon PCI card, "glxinfo" shows 
direct rendering: No, lsmod does not have an entry for 
ATI. "/usr/src/linux-2.4/drivers/pci/pci.ids" does not include the entry 
for device id 5144 radeon_drv.o also modprobe causes error see below.

How Reproducible:
100%


Steps to Reproduce:
1. Install RH7.1 with ATI card.
2. Run Xconfigurator
3. 

Actual Results: radeon module is not used, dri =No


Expected Results:


Additional Information:

Running "lspci; lspci -n" gives the following results:

[root@localhost /root]# lspci; lspci -n
00:00.0 Host bridge: Intel Corporation 82840 840 (Carmel) Chipset Host 
Bridge (Hub A) (rev 01)
00:01.0 PCI bridge: Intel Corporation 82840 840 (Carmel) Chipset AGP 
Bridge (rev 01)
00:02.0 PCI bridge: Intel Corporation 82840 840 (Carmel) Chipset PCI 
Bridge (Hub B) (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 
5144
02:1f.0 PCI bridge: Intel Corporation 82806AA PCI64 Hub PCI Bridge (rev 02)
03:00.0 PIC: Intel Corporation 82806AA PCI64 Hub Advanced Programmable 
Interrupt Controller (rev 01)
04:04.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
04:07.0 Ethernet controller: 3Com Corporation 3c905C-TX [Fast Etherlink] 
(rev 78)
00:00.0 Class 0600: 8086:1a21 (rev 01)
00:01.0 Class 0604: 8086:1a23 (rev 01)
00:02.0 Class 0604: 8086:1a24 (rev 01)
00:1e.0 Class 0604: 8086:2418 (rev 02)
00:1f.0 Class 0601: 8086:2410 (rev 02)
00:1f.1 Class 0101: 8086:2411 (rev 02)
00:1f.2 Class 0c03: 8086:2412 (rev 02)
00:1f.3 Class 0c05: 8086:2413 (rev 02)
01:00.0 Class 0300: 1002:5144
02:1f.0 Class 0604: 8086:1360 (rev 02)
03:00.0 Class 0800: 8086:1161 (rev 01)
04:04.0 Class 0401: 1013:6003 (rev 01)
04:07.0 Class 0200: 10b7:9200 (rev 78)

Running "lspci -vn" gives the following partial results:

01:00.0 Class 0300: 1002:5144
	Subsystem: 1002:108a
	Flags: stepping, 66Mhz, medium devsel, IRQ 9
	Memory at e8000000 (32-bit, prefetchable) [size=128M]
	I/O ports at ec00 [size=256]
	Memory at fcf80000 (32-bit, non-prefetchable) [size=512K]
	Expansion ROM at 80000000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

Results of `modprobe radeon`

Note: /etc/modules.conf is more recent than /lib/modules/2.4.2-
2/modules.dep
/lib/modules/2.4.2-2/kernel/drivers/char/drm/radeon.o: init_module: Cannot 
allocate memory
/lib/modules/2.4.2-2/kernel/drivers/char/drm/radeon.o: 
insmod /lib/modules/2.4.2-2/kernel/drivers/char/drm/radeon.o failed
/lib/modules/2.4.2-2/kernel/drivers/char/drm/radeon.o: insmod radeon failed
Hint: insmod errors can be caused by incorrect module parameters, 
including invalid IO or IRQ parameters
Comment 1 Arjan van de Ven 2001-05-14 11:34:01 EDT
Does "modprobe agpgart" succeed ?
Comment 2 Yu-Pa Ng 2001-05-14 11:46:42 EDT
`modprobe agpgart` successfully probed agpgart.  
Then, `modprobe radeon` succeeded as well.   After restarting X window, `lsmod`
shows radeon is unused.  DRI is still disabled.
Comment 3 Arjan van de Ven 2001-05-14 11:48:19 EDT
Is DRI enabled in the XFree config ?
Comment 4 Yu-Pa Ng 2001-05-14 12:13:27 EDT
Created attachment 18293 [details]
Yes, Dri is enabled in XFree Config.  Plese see the enclosed /etc/X11/XF86Config-4 file.
Comment 5 Mike A. Harris 2001-05-15 04:45:58 EDT
Read the RELEASE-NOTES that come on the first CDROM.  XFree86 4.0.3 does
not support DRI on the ATI Radeon.  Our kernel ships with the Radeon DRM
module in the hopes that a future XFree86 release that does support the
Radeon 3D accelerated will hopefully just drop in without a kernel
upgrade.

Currently in order to get 3D acceleration in XFree86 you need to use the
CVS head branch of XFree86, or wait until XFree86 4.1.0 is released.

Note You need to log in before you can comment on or make changes to this bug.