Bug 40575 - Failed installation if /usr/share is read-only
Failed installation if /usr/share is read-only
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libtool (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 15:02 EDT by Enrico Scholz
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 16:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-05-14 15:02:23 EDT
Description of Problem:

My /usr/share is NFS-mounted and shared between some systems. To prevent
unsolicited actions, this directory is mounted read-only and put into rpm's
%_netsharedpath.

The libtool's %post install script wants writing access to
/usr/share/doc/libtool-1.4/demo and fails because this is not allowed. This
failure leads to a slight corruption of the rpm-database:

-----------------
$ rpm -q libtool
libtool-1.4-1

$ rpm -U /usr/src/redhat/RPMS/i386/libtool-1.4-2.i386.rpm
You should update your `aclocal.m4' by running aclocal.
rm: cannot unlink `config.guess': Read-only file system
...
Error: execution of %post scriptlet from libtool-1.4-2 failed, exit status
1

$ rpm -q libtool
libtool-1.4-1
libtool-1.4-2
-------------------


To prevent this I suggest to add the line marked with `+' to the scriptlet:

-------------------
  /sbin/install-info /usr/share/info/libtool.info.gz /usr/share/info/dir
  # XXX hack alert
  cd /usr/share/doc/libtool-1.4/demo || cd /usr/doc/libtool-1.4/demo ||
exit 0
+ { touch .test-write 2>/dev/null && rm -f .test-write; } || exit 0
  libtoolize --copy --force
  aclocal
...
-------------------


Steps to Reproduce:
1.  mount -o remount,ro /usr; echo '%_netsharedpath  /usr'
>>/etc/rpm/macros
2.  rpm -U libtool-1.4-2.i386.rpm --force
Comment 1 Florian La Roche 2001-06-12 07:35:33 EDT
I have disabled the post script writing into /usr/share completely. That doesn;t
make
any sense.

Thanks for this bug-report,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.