Bug 405921 - name service switch doesn't seem to work on current install images
Summary: name service switch doesn't seem to work on current install images
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-30 14:46 UTC by Lubomir Kundrak
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-30 19:26:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tty2 (13.93 KB, image/png)
2007-11-30 14:51 UTC, Lubomir Kundrak
no flags Details

Description Lubomir Kundrak 2007-11-30 14:46:47 UTC
Description of problem:

I could not save exception logs as ssh/scp did not work. Host name resolution
didn't work, so I suspect it was nss what had problems.

Version-Release number of selected component (if applicable):

anaconda-11.4.0.3-1 with with partedUtils.py fix.

Additional info:

/etc/passwd has whitespace at the beginning. That's not related with this
problem, maybe it's not even a problem, but it just doesn't look correct, or at
least nice.

Comment 1 Lubomir Kundrak 2007-11-30 14:46:47 UTC
Created attachment 273851 [details]
(accidentelly attached, ignore)

Comment 3 Lubomir Kundrak 2007-11-30 14:51:08 UTC
Created attachment 273881 [details]
tty2

Comment 4 Chris Lumens 2007-11-30 19:26:40 UTC
This is a result of more nss libraries not being included in the install images
because they are dlopened instead of being linked against.  I've added them to
upd-instroot, but it's possible even more things will be needed in the future. 
For now, you can just stick /lib/libnss_dns* and /lib/libnss_files* into an
updates image.


Note You need to log in before you can comment on or make changes to this bug.