Bug 406011 - DPMS only turns monitor off half the time
DPMS only turns monitor off half the time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 11:00 EST by long
Modified: 2009-06-30 19:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 10:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (296.79 KB, text/plain)
2007-11-30 11:00 EST, long
no flags Details
xorg.conf (1.68 KB, text/plain)
2008-02-04 11:42 EST, long
no flags Details
Xorg.0.log when no xorg.conf is present (72.73 KB, text/plain)
2008-02-04 11:43 EST, long
no flags Details

  None (edit)
Description long 2007-11-30 11:00:47 EST
Description of problem:

I'm not sure I've assigned this to the right component or not so please
re-assign if appropriate.  

I'll attach my xorg log but I'm using some sort of ATI card connected to two
monitors.  I'm running KDE and xset -q reports:


DPMS (Energy Star):
  Standby: 720    Suspend: 1800    Off: 3600
  DPMS is Enabled
  Monitor is On

The problem is that half the time I come in to work and find the monitors are
still on, showing what appears to be a frozen screensaver.  If I login from a
remote machine and run xset -q from there it reports: "Monitor is Off" which it
clearly is not.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.196-1.fc8

How reproducible:
not, seems random

Steps to Reproduce:
1. Start KDE Control Center
2. Open Peripherals
3. Click Display
4. Click Power Control tab
5. Turn on Enable display power management
6. Set Standby to 12 min, Suspend to 30, Power off to 60
7. Click Apply
8. Let computer set idle for a while 
  
Actual results:
Sometimes the monitors will power off at the expected time.  Sometimes they do
not, instead showing what appears to be a frozen screensaver even though 'xset
-q' reports that the monitors are off.

Expected results:
Monitors always turn off.

Additional info:
Comment 1 long 2007-11-30 11:00:47 EST
Created attachment 273951 [details]
xorg log
Comment 2 Matěj Cepl 2008-01-31 11:35:54 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachment using the bugzilla file attachment
link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 long 2008-02-04 11:42:40 EST
Created attachment 293907 [details]
xorg.conf
Comment 4 long 2008-02-04 11:43:34 EST
Created attachment 293908 [details]
Xorg.0.log when no xorg.conf is present
Comment 5 Dave Airlie 2008-05-09 01:15:06 EDT
does this happen with the latest F8 of F9 ati drivers still?

Comment 6 long 2008-05-09 10:27:17 EDT
It is either not happening at all anymore or it has become much more infrequent.
 Either way I'm happy with its behavior now.

Note You need to log in before you can comment on or make changes to this bug.