Bug 40615 - recieved signal 11
recieved signal 11
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 22:24 EDT by William Ackerman
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Ackerman 2001-05-14 22:24:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-20mdksmp i686)

Description of problem:
Intalller fails while running anaconda

System Outline
------------
Dual PIII
Gigabyte 6VXD7 Motherboard
with VIA Chipset 
128 Mb Ram 
20 Gig WD ATA 100 
nvidia TNT2 Video
Creative Lab DVD-1243E
Eagle TR3 Drive
two Realtek (PCI-NE2000 compat) NIC
Logitech PS2 Mouseman+
17 Samsung Generic VGA Monitor
UPS APC 600
Currently System is Running Redhat 7.0 with no Problems...
When I start to run the install from the CDROM #1 to upgrade my RH7.0
system to 7.1 after Anaconda start I get the following error
Running anaconda - please wait...
xxx lineno: 76, opcode:0
'import exceptions' failed; use v for traceback
Warning! Falling bac to string - based exceptions
install exited abnormally -- recieved signal 11
sending termination signals ... done
sending kill signals ... done
disabling swap...
unmounting fialsystem...
    /proc/bus/usb
    /mnt/runtime
    /mnr/source unmount failed ()
    /dev/pts
    /proc
you may safely reboot your system

Any help so that I might get the system upgraded would be welcome...


How reproducible:
Always

Steps to Reproduce:
1.install CDrom RH7.1 #1
2.boot system
3.hit enter at the boot: prompt
4. error as described above.
	

Actual Results:  Running anaconda - please wait...
xxx lineno: 76, opcode:0
'import exceptions' failed; use v for traceback
Warning! Falling bac to string - based exceptions
install exited abnormally -- recieved signal 11
sending termination signals ... done
sending kill signals ... done
disabling swap...
unmounting fialsystem...
    /proc/bus/usb
    /mnt/runtime
    /mnr/source unmount failed ()
    /dev/pts
    /proc
you may safely reboot your system


Expected Results:  System should boot in to Xwindow and ask me to select
the language as installation instruction state.

Additional info:

System Outline
------------
Dual PIII
Gigabyte 6VXD7 Motherboard
with VIA Chipset 
128 Mb Ram 
20 Gig WD ATA 100 
nvidia TNT2 Video
Creative Lab DVD-1243E
Eagle TR3 Drive
two Realtek (PCI-NE2000 compat) NIC
Logitech PS2 Mouseman+
17 Samsung Generic VGA Monitor
UPS APC 600
Currently System is Running Redhat 7.0 with no Problems...
Comment 1 Brent Fox 2001-05-15 00:47:16 EDT
Can you try booting with 'linux ide=nodma'?  Does that help?
Comment 2 William Ackerman 2001-05-15 21:47:22 EDT
I tried as you suggested as it still fail but not I fail with both 
xxx lineno: 76 : opcode: 0
and 
xxx lineno 35: opcode: 0

ready for your next suggestion...
Comment 3 Brent Fox 2001-05-16 16:13:07 EDT
Are you sure that the cd's are good?  This is a pretty bizarre error messages. 
I haven't seen anything like this before.
Comment 4 William Ackerman 2001-05-16 17:08:35 EDT
The are right out of the red box (I got it from Best Buy two weeks ago) and I 
was able to install 7.1 on my test computer just fine.  In fact i have been 
running 7.1 on my test system for about 10 days with no problem.  It is just 
the production system needs to be upgraded.  In fact you can see 7.0 running 
just fine by looking at my web page www.acknet.net  I just can't upgrade the 
system from a working 7.0 to 7.1 I really want the 2.4 kernel.  Is there any 
other information that I can provide you to help...  If you go to the www.giga-
byte.com web page and look for my mother board would that help.  Here is the 
product discription of my board http://www1.giga-byte.com/products/6vxd7.htm  
it is a good board.  If you think I need new disks what would I need to do the 
get better/good/fixed/whatever you think I need disks.
Comment 5 Brent Fox 2001-05-17 16:11:42 EDT
Do you have any other machines that you can test this cd out on?  I've got a bad
feeling that the cd is damaged somehow, because this error message usually
denotes some kind of data corruption (in this case, on the cd).  If the same
thing happens on another machine, I would return the cd's to Best Buy and
exchange it for a new set.
Comment 6 Matt Wilson 2001-05-17 16:25:59 EDT
The "XXX lineno: 14, opcode: 0" is an internal Python error that can only happen
due to corrupted input opcode streams.  This points to one of the following:

1) bad media
2) bad CD-Rom drive
3) bad IDE controller
3) some bug in the kernel that causes data read from the CD-Rom drive to be
corrupted.

I'm assigning this to the kernel, there's nothing more the Anaconda team can do
to fix this one.
Comment 7 Arjan van de Ven 2001-05-17 16:29:08 EDT
Ok. I'd appreciate "lspci -v" output (from 7.0, that's fine) and 
output of "cat /proc/ide/*/model" ...
That would give me more exact information about your hardware.
Comment 8 William Ackerman 2001-05-17 17:34:50 EDT
Here is the info you requested.  I really want to get this working ASAP.
[root@admin bill]# cat /proc/ide/*/model
Maxtor 52049H4
CREATIVE DVD-ROM DVD1243E
pci
[root@admin bill]#

I have RH 7.1 working on another system. And it worls just fine in fact I use 
it as a workstation.  This system that I am having the problem with is my 
Development/firewall/server.  Is there anything else I can send you...
Comment 9 William Ackerman 2001-05-17 17:51:48 EDT
Here is the rest of the information you wanted:
Linuxconf 1.25r3                                                            
   Host name: admin.acknet.net                                                
 
   File /proc/version                                                         
 
      Linux version 2.2.19-7.0.1smp (root@porky.devel.redhat.com) (gcc versi  
 
   Output of command: /usr/bin/uptime                                         
 
        4:49pm  up 23:21,  3 users,  load average: 0.03, 0.01, 0.00           
 
   File /proc/cpuinfo                                                         
 
      processor       : 0                                                     
 
      vendor_id       : GenuineIntel                                          
 
      cpu family      : 6                                                     
 
      model           : 8                                                     
 
      model name      : Pentium III (Coppermine)                              
 
      stepping        : 1                                                     
 
      cpu MHz         : 498.172                                               
 
      cache size      : 256 KB                                                
 
      fdiv_bug        : no                                                    
 
      hlt_bug         : no                                                    
 
      sep_bug         : no                                                    
 
      f00f_bug        : no                                                    
 
      coma_bug        : no                                                    
 
      fpu             : yes                                                   
 
      fpu_exception   : yes                                                   
 
      cpuid level     : 2                                                     
 
      wp              : yes                                                   
 
      flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge  
 
      bogomips        : 992.87                                                
 
                                                                              
 
      processor       : 1                                                     
 
      vendor_id       : GenuineIntel                                         
      cpu family      : 6                                                     
 
      model           : 8                                                     
 
      model name      : Pentium III (Coppermine)                              
 
      stepping        : 1                                                     
 
      cpu MHz         : 498.172                                               
 
      cache size: 256 KB                                                
 
      fdiv_bug        : no                                                    
 
      hlt_bug         : no                                                    
 
      sep_bug         : no                                                    
 
      f00f_bug        : no                                                    
 
      coma_bug        : no                                                    
 
      fpu             : yes                                                   
 
      fpu_exception   : yes                                                   
 
      cpuid level     : 2 
      cpuid level     : 2                                                     
 
      wp              : yes                                                   
 
      flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge  
 
      bogomips        : 996.14                                                
 
                                                                              
 
                                                                             
                                                                              
 
   Output of command: /sbin/lspci -v                                          
 
      00:00.0 Host bridge: VIA Technologies, Inc. VT82C691 [Apollo PRO] (rev  
 
              Flags: bus master, medium devsel, latency 0                     
 
              Memory at e0000000 (32-bit, prefetchable)                       
 
              Capabilities: [a0] AGP version 2.0                              
 
              Capabilities: [c0] Power Management version 2                   
 
                                                                              
 
      00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598 [Apollo MVP3 AGP]   
 
              Flags: bus master, 66Mhz, medium devsel, latency 0              
 
              Bus: primary=00, secondary=01, subordinate=01, sec-latency=0    
 
              I/O behind bridge: 0000a000-0000afff                            
 
              Memory behind bridge: dde00000-dfefffff                         
 
              Prefetchable memory behind bridge: d9c00000-ddcfffff            
 
              Capabilities: [80] Power Management version 2                   
 
                                                                              
 
                                                                              
 
      00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super] (re  
 
              Subsystem: VIA Technologies, Inc. VT82C686/A PCI to ISA Bridge  
 
              Flags: bus master, stepping, medium devsel, latency 0           
 
                  
 
      00:07.1 IDE interface: VIA Technologies, Inc. VT82C586 IDE [Apollo] (r  
 
              Flags: bus master, medium devsel, latency 32                    
 
              I/O ports at ffa0                                               
 
              Capabilities: [c0] Power Management version 2                   
 
                                                                              
 
      00:07.2 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 10)   
 
              Subsystem: Unknown device 0925:1234                             
 
              Flags: bus master, medium devsel, latency 64, IRQ 19            
 
              I/O ports at cc00                                             
    
              Capabilities: [80] Power Management version 2                   
 
                                                                              
 
      00:07.3 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 10)   
 
              Subsystem: Unknown device 0925:1234                             
 
              Flags: bus master, medium devsel, latency 64, IRQ 19            
 
              I/O ports at d000                                               
 
              Capabilities: [80] Power Management version 2                   
 
                                                                              
 
      00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (re  
 
              Flags: medium devsel                                            
 
              Capabilities: [68] Power Management version 2                   
 
                                                                              
 
      00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(  
 
              Flags: medium devsel, IRQ 18                                    
 
              I/O ports at d400                                             
   
                                                                         
      00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(  
 
              Flags: medium devsel, IRQ 19                                    
 
              I/O ports at d800                                               
 
                                                                              
 
      00:0e.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev  
 
              Subsystem: Giga-byte Technology: Unknown device 2060            
 
              Flags: bus master, slow devsel, latency 64, IRQ 18              
 
              I/O ports at dc00                                               
 
              Capabilities: [dc] Power Management version 1                   
 
                               
 
      01:00.0 VGA compatible controller: nVidia Corporation Vanta [NV6] (rev  
 
              Subsystem: CardExpert Technology: Unknown device 8888           
 
              Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 16     
 
              Memory at de000000 (32-bit, non-prefetchable)
              Memory at da000000 (32-bit, prefetchable)                       
 
              Expansion ROM at dfef0000 [disabled]                            
 
              Capabilities: [60] Power Management version 1                   
 
              Capabilities: [44] AGP version 2.0                             
Comment 10 Arjan van de Ven 2001-05-18 03:52:52 EDT
If your firewall has about 1.3 Gb of free space, could you try the following:

dd if=/dev/cdrom of=/seawolf-i386-disc1.iso		(with CD1 in the drive)
dd if=/dev/cdrom of=/seawolf-i386-disc2.iso		(with CD2 in the drive)

(you can also pick another location for the destination files)
You can do a harddisk install now. If this succeeds, it means the cdrom-drive 
is the problem, if this also fails... I have to think of something else.

Oh, and if you have a network, please do this on the other machine as well and
compare md5sums of the iso's to make sure they are identical between drives..
Comment 11 William Ackerman 2001-05-18 11:14:45 EDT
I am currently at work right now (10:15am CST) and I will try your suggestion 
as soon as I get home (6:00pm CST) and let you know the results. Again thanks..
Will anyone be in over the weekend?  I would Like to solve this quick.
Comment 12 Arjan van de Ven 2001-05-18 11:18:22 EDT
I usually read mail in weekends
Comment 13 William Ackerman 2001-05-18 21:36:19 EDT
Ok I ran the code you suggested:
Here are the results:

[root@admin/share] # dd if=/dev/cdrom of=/seawolf-i386-disc1.iso
hdb: ATAPI 40XDVD-ROM drive, 512 Cache
hdb: irg timeout: status=0xd0 { Busy }
hdb: ATAPI reset complete
1314120+0 records in
1314120+0 records out
[root@admin/share] # dd if=/dev/cdrom of=/seawolf-i386-disc2.iso
1306372+0 records in
1306372+0 records out
[root@admin/share]

Ready... for next suggestions...
Comment 14 Arjan van de Ven 2001-05-19 04:21:43 EDT
Now, if you can get those files on your firewall machine, you can make a
bootfloppy and do a "harddisk install".
The harddisk-install will use the .iso files; if that succeeds it is a
cdromdrive thing.
Comment 15 William Ackerman 2001-05-21 20:18:17 EDT
I tried what you suggested on Saturday and still no luck... I still get the same
error.  So sunday I got a brand new CD-RW and HP-cdwriter 9500i (on sale at SAMS
for $119.91 great deal for an HP Burner).  Again, RH7.0 saw the new drive and
the reassignment of the old drive.  In fact I am on the 7.0 system now so I know
that it isn't the CD-Rom
then I tried to install from the NEW HP drive and I am getting the same error.
as before. So on a whim I get a second HD a WD 30 Gig ATA100 and pulled out the
old drive to do a virgin installation and still I get the error as stated
above....   HELP!!!!!What else can I do!!!!   I even went so far as to hunt down
the lates bios for this system and installed it...   Still no luck....  I even
sent Alan Cox an e-mail to ask him about possable problems with the VIA chipset
and kernel 2.4.  He told me that it only is a problem with the AMD + VIA combo
with 2.4.  So I shouldn't be having this problem. Any other suggentions I might
try.  Would you suggest trying to install another distro on that blank 30Gig
just to see if it works?
Comment 16 Arjan van de Ven 2001-05-22 05:03:58 EDT
I'm out of normal things to try, so maybe this strange thing is worth a shot:
if you "dd" CD1 to 2 different .iso files (eg do it twice with a different
filename), do the md5sum's match ?
Comment 17 William Ackerman 2001-05-22 11:29:47 EDT
I will try as you suggest.  Here is a follow up note...  I download another 
Distro just for kicks and grins (Mandrake 8.0) and tried to install it on that 
blank 30 gig HD.  I get the same error signal 11.  Does that help "you are not 
alone!" I really want my Redhat 7.1:(  What in kernel 2.4 installation could be 
going belly-up  is there a way for me to capture the install to a file and send 
it to you? the reason why I ask is a lot of stuff flies across the before I get 
a blue screen and anaconda start and the crashes.  Is there a parameter to 
write what is going on as RH 7.1 starts to a floppy disk file?  The I can send 
you my actual boot dialog if that would help.
Comment 18 Arjan van de Ven 2001-05-22 11:37:14 EDT
Ok, so it sounds more like a 2.4 kernel issue. Could you try the following:
download the 2.4.3-5 kernel from rawhide (yes I know that sounds unstable but
the 2.4.3-5 and 2.4.3-7 kernels are VERY stable) and try it on the 7.0
installation?
(you will have to --nodeps --force install it)

Comment 19 William Ackerman 2001-05-22 15:25:57 EDT
Ok, then here is what I am going to do...  On the blank 30 Gig dh I am going to 
install RH 7.0 and then I will install Rawhide on top of that.  I really don't 
want to mess up a working system.  I will try to do it tonight 5/22/01 but that 
depends on what my wife wants me to do from the "Honey do" list.  I'll let you 
know how it goes...  Keep your fingers crossed...

Thanks again for your time...
Comment 20 William Ackerman 2001-05-22 22:26:26 EDT
Here is my current staus, I have just installed RH7.0  It went as smooth as a
babies bottom.  I am now getting the Rawhide kernel.
Comment 21 William Ackerman 2001-05-23 14:35:40 EDT
I have a question.  I downloaded the 2.4.3-5 kernels as you suggested and I 
thought that I linked the new kernel correctly inside the /boot directory, but 
when I reboot my system, I think it is still booting into 2.2.  What can I 
check to be sure that I have the links correct?  The variable KERNEL still has 
2.2 listed as the version.  What do I need to check/change?
Comment 22 Arjan van de Ven 2001-05-23 14:37:35 EDT
Check /etc/lilo.conf
and remeber, everytime you change that run /sbin/lilo
Comment 23 William Ackerman 2001-05-24 00:26:41 EDT
Ok.... Here is the scoop!!!
1) I was able to link and configure 2.4.3-5  I needed to run /sbin/lilo and 
everything fell right into place...
2)Good news the SMP version of 2.4.3-5 booted and ran fine....
3)Bad news the single processor version failed like a stuck pig and here is the 
results:

Starting kswapd v1.8 <---the last good lin during the boot.
Invalid operand: 000
Cpu: 0
EIP: 0010:[<c0129acb>]
EFLAGS: 00010246
eax: 00000000 ebc: c13012b4 ecx: c13012ac edx: c13012ac
esl: c13012a5 edi: c020a241 ebp: 00000000 esp: c1307f90
ds: 0018 es: 0018 ss: 0018
Process swapper (pid:1, stackpage = c1307000
stack: c1307f94 00000020 c028a90c 00000000 c0105000 0008e000 c0258414 c020a234
       00000010 00000020 00000000 00000000 00000000 c024e942 00000001 c024e9d2
       c024dfc4 00010f00 c024dfc4 c01050e9 00010f00 c024dfc4 c0105000 0008e000
call trace: [<c0105000>] [<c020a234>] [<c01050e9>] [<c0105000>] [<c0105596>]
 [<c01050e0>]
Code: 0f 0b 8b 12 81 fa fc 6d 23 c0 75 d9 8d 43 5c 89 41 04 89 4b
<0> Kernel panic: Attempted to kill init

I think this is the problem...  If I am not mistaken, when you install/upgrade 
the system it runs in single processor mode....  I think this is our error...
Comment 24 Arjan van de Ven 2001-05-24 08:12:23 EDT
Ah Ha!
http://people.redhat.com/dledford/440gx
has a special bootfloppy that emulates most of an SMP kernel when you
pass the "apic" parameter on the syslinux prompt.

(btw, 2.4.3-5 has such a parameter as well)

That might be worth trying
Comment 25 William Ackerman 2001-05-24 10:40:09 EDT
Ok, this is what I'll do.
1) I'll try to install RH7.1 as a virgin install on the test
   disk that I have been working with the boot floppy I just made.
2) If it works I'll then re-install RH 7.0 and try to do an upgrade
   to RH 7.1
3) If that works I'll let it run for a time as a test system.
4) If that goes well I'll then do a backup of my production system
   and run the upgrade to RH 7.1 using the boot floppy and see how that
   goes.

Is there anything else I should look at or do?  
Comment 26 William Ackerman 2001-05-24 23:29:49 EDT
I still get the same error Ahhhhhh!!!  What is going on here!!!!
Do you have any other suggestions?
Comment 27 William Ackerman 2001-05-29 19:19:55 EDT
Hay guys,  Do you have any other suggestions?
Comment 28 Arjan van de Ven 2001-05-30 04:06:48 EDT
You did specify "apic" as option to the new bootfloppy ?
Comment 29 William Ackerman 2001-05-30 13:09:34 EDT
I thought I did it right.  Please could you tell me the correct way to add 
the "apic" option to the floppy boot.  I have created the Image from the link 
you provided ehdn the boot prompt comes up what do I type?
boot: what?
Comment 30 Arjan van de Ven 2001-05-30 13:11:17 EDT
"linux apic"
(without the ""'s)
Comment 31 William Ackerman 2001-05-30 17:12:30 EDT
That is exactly what I typed...  Letter for letter.  It still crashed.... I 
will try again... but what else could I try.
Comment 32 Arjan van de Ven 2001-05-31 05:11:03 EDT
One more idea: what happens if you boot with
"mem=126M"
(yes 126 not 128)
Comment 33 William Ackerman 2001-06-11 12:15:34 EDT
Still no luck,  I tried both the floppy and the CD and had no luck.  I tryed 
all possible combos of "linux apic mem=126m" and "mem=126m" alone on both the 
floppy image you gace me and the CD boot any other suggestion I can try?
Comment 34 William Ackerman 2001-06-12 10:14:07 EDT
I had a problem pop up with Windows ME that has been very inconsistant.  I 
think that it might have a baring on the error that I am having with RH7.1.  It 
seems that one out of ever two boots into ME results in a VKD error and locks 
the windows system so I went out to the web to find out what VKD was and found 
that it is a keyboard driver. And the error is from a bad signal from the 
Keyboard.  So this afternoon I am going to go get a logitech keyboard and try 
it to see if it fixes the ME error.  Then I'll try it on RH7.1 after all is 
said and done I'll let you know the results.  I have had my current Keyboard 
for over 3 years and have had no problems that I know of.  So lets see what 
happens if I swap keyboards.  I'll keep you updated with the results...
Comment 35 William Ackerman 2001-06-13 09:34:48 EDT
No luck.  I got two different Keyboards and in both cases the install fail 
after anaconda started.  Please give me some guidence.
Comment 36 William Ackerman 2001-06-13 10:34:46 EDT
is there a newer version of anaconda/kernel/syslinux that I can try. I am so 
frustrated.....
Comment 37 William Ackerman 2001-06-16 21:31:01 EDT
Please provide some help, I have switch my key board and mouse I have tried
everything that I can please help me......
Comment 38 Arjan van de Ven 2001-06-17 07:36:04 EDT
I'm out of useful ideas.. maybe an NFS install will work
(eg make a floppy from bootnet.img and copy the contents of both cd's
into a directory on your other machine, NFS accessible)
Comment 39 William Ackerman 2001-06-19 12:24:27 EDT
Still no luck. God I feel Stuck....   Is there anyone else we could send this 
to that might have some insight.  Could there be a memory issue, CPU issue, 
Chipset issue,  at this point I am willing to try just about anything.
Comment 40 Carlos Saldarriaga 2001-06-19 21:08:33 EDT
Hi,
I am having a similar problem installing 7.1 on a new system:
Mobo - Gigabyte's GA-7DX
Processor - Athlon Thunderbird 1200
Video - ATI Xpert98 AGP (a RageXL chip with 8M)
Adaptec 19160 scsi controller card
Seagate 18.4GB 15rpm Cheetah scsci disk
3com etherlink PCI server NIC adapter
512Mg DDR SDRAM - Mushkin
Creative Labs - CD 52X EIDE cd-rom

I have tried recommendations here and on bug 29555 as I appear to have both the 
aic7xxx problem and the signal 11 problem described here.  I have installed 
using the new images with apic option, the ide=nodma option, removed the scsci 
card and tried installing on a 10G IDE drive, all with no luck.
Sometimes the installer can't recognize the CD when in expert mode, others I 
can't get past the Xserver starting.  When I am lucky (or unlucky as I spend 
more time selecting the packages) I get to the format one or two partitions and 
then receive a critical error indicating formating can't go on (Ctr+Alt+F1 
sometimes shows scsci error, and sometimes CPU errors).
I am curious about Alan Cox's comments on problems with the AMD+Via combo, as 
this is my case.
I bought the Deluxe Workstation box with 60 day install support, but the 
support so far was to check bugzilla, which I already had.  Very dissapointing.
I am open to suggestions.
Comment 41 William Ackerman 2001-06-22 10:07:00 EDT
What is the difference between 2.4 and 2.2 installation that would cause these 
types of problems,  maybe someone from redhat should send Alan Cox a message 
and see what he says.  This is a real bummer guys...
Comment 42 Alan Cox 2001-06-22 12:04:15 EDT
Unfortunately looking at the report I have no idea beyond what has already been
suggested. Reading the report Im pretty sure the CD-ROM is fine, the CD images
are fine and something else is causing memory corruption.

The fact the SMP kernel works and the uniprocessor one fails is in itself quite
odd. That is backwards to the normal case. The only thing that SMP does not do
that uniprocessor does is APM. I would be interested to know if a kernel built
without APM support worked. 

Arjan - does our install kernel have APM or not ?

Alan
Comment 43 Arjan van de Ven 2001-06-22 12:07:11 EDT
BOOT kernel doesn't have APM (it takes space :)
Comment 44 William Ackerman 2001-06-22 16:23:00 EDT
I just saw somthing on Linuxtoday from Alan Cox, Would this help you in 
debugging my problem. Here is the web page...
http://linuxtoday.com/news_story.php3?ltsn=2001-06-22-008-20-PS
Comment 45 William Ackerman 2001-06-26 09:31:16 EDT
I am going to try something this week, tell me what you think.  Currently, I 
have 128 megs of ram, I am going to up it to 374.  Do you think that it will 
make any difference?
Comment 46 Arjan van de Ven 2001-06-26 09:32:30 EDT
Also interesting would be using ONLY the new ram
Comment 47 William Ackerman 2001-07-09 12:02:11 EDT
Still No luck I get the same error.
Here is what I did.
1) pulled out the old memory and put in a new chip from a different vendor. and 
tried to install it dies after Anaconda.  I even ran it with the different 
parameters as stated above. apic and mem=126M and ide=nodma. 
2) I installed more memory  now at 256M tried the same thing still no luck even 
with paramteres.  Any other suggenstion.  Has anybody else reported error with 
this type of motherboard (Gigabyte) and the VIA chipset?
Comment 48 William Ackerman 2001-07-16 12:41:55 EDT
Alan Cox just released a fix to the VIA Chip set. Could you please let me know 
if this is useful to me.   The chip set sound just like the I have IE sound on 
the mother board.  Please Get back to me quick I really want to get this 
going...
Comment 49 Carlos Saldarriaga 2001-07-16 18:49:24 EDT
As I reported, I had a similar problem with a Gigabyte's GA-7DX.  The only way 
to be able to install was to lower the Front Side Bus speed to 100Mhz through 
the board jumpers.  This lowers the processor speed as well.
Don't know if this relates to your problem, but its worth a shot.
Comment 50 Arjan van de Ven 2001-07-18 05:40:27 EDT
I'll have a more detailed look, but afaik we had this already in 2.4.2-12
Comment 51 William Ackerman 2001-07-18 10:15:40 EDT
carloseduard, You are running an AMD processor, correct?  I am running two P3 
500e.  I don't think it would act the same.  If arjanv says to try it I'll hunt 
down a way to slow down the bus if I can.
Comment 52 William Ackerman 2001-07-31 12:52:23 EDT
Hay people whats happening.....   I don't want to be stuck out here for so long.
Comment 53 William Ackerman 2001-08-02 13:30:23 EDT
Hay!!!! Roswell is out on beta,  Should I get a copy and try it on my system???
I really want to get this going....  Please, please respond to this message...  
Has Anaconda been updated. would this be a vaild test.....
Comment 54 Arjan van de Ven 2001-08-02 13:55:40 EDT
Anaconda is updated A LOT. So it's worth testing it, even if you only do a
minimal FTP install if you don't have lots of bandwidth.
Comment 55 Alan Cox 2001-08-02 13:57:15 EDT
You can certainly try it - my feeling is that it wont make any difference
because the problem seems to be hardware not software
Comment 56 William Ackerman 2001-08-06 10:27:26 EDT
You were right Alan.  It still won't run after anaconda start to load.  Now, I 
have a question for you.  Why do you think that it is a hardware error?  The 
same conputer is running with no problem RH7.0 in SMP.  SHould I look for a new 
motherboard?  What type would you recommend for dual p3 500e?  I want to try to 
save all my hardware other than the motherboard.  Should I just dump everything 
and start from scrach?
Comment 57 William Ackerman 2001-08-14 10:00:34 EDT
Is there any one out there!!  Tell me what you think I should do/try...
Comment 58 William Ackerman 2001-08-28 15:08:02 EDT
Hay Guys,  Please Talk to ME...  What other options do you suggest?
Comment 59 Alan Cox 2001-08-28 17:39:28 EDT
I've nothing else to suggest. We have other folks with the same mainboard, same
bios and same basic setup running RH 7.1. The traces you have post all point to
"impossible" situations and look like hardware issues.

2.2 and 2.4 will load memory and use things in different ways. The fact your
windows me has crashes also sounds the same thing.
Comment 60 Bugzilla owner 2004-09-30 11:39:00 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.