Bug 406171 - 3.7: Description field in the bug status table.
3.7: Description field in the bug status table.
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
2 hours for selenium testing
:
Depends On:
Blocks: RHBZ30UpgradeTracker 427052
  Show dependency treegraph
 
Reported: 2007-11-30 11:58 EST by David Lawrence
Modified: 2013-06-24 00:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 20:05:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that we applied to rh_bugzilla_2_18 to have use the new desription field in the bug status table (10.35 KB, text/plain)
2007-12-19 10:48 EST, Noura El hawary
no flags Details
patch to pull out status description from bug status table (3.22 KB, patch)
2008-02-12 12:46 EST, Noura El hawary
nelhawar: review-
Details | Diff
bug status description patch (1.77 KB, patch)
2008-02-14 09:11 EST, Noura El hawary
no flags Details | Diff
Bug status description patch (dkl) (8.28 KB, patch)
2008-02-14 15:00 EST, David Lawrence
no flags Details | Diff

  None (edit)
Description David Lawrence 2007-11-30 11:58:06 EST
Description:
Red Hat has added an additional column to the bug_status table to keep the description for each status. The description is used in show_bug.cgi to display whenever a user mouses over one of the statuses in the drop down field.

Function Requirements:
Additional column needs to be added to the bug_status table. A description should be added for each status in the table. globals.pl needs to be updated to load the data into the bug_status_desc hash for use by template/en/default/bug/knob.html.tmpl.
Comment 1 Noura El hawary 2007-12-19 10:48:20 EST
Created attachment 290035 [details]
patch that we applied to rh_bugzilla_2_18 to have use the new desription field in the bug status table
Comment 2 Noura El hawary 2007-12-19 10:56:16 EST
LOC estimation Using Historical data:

From the attached patch in the previous comment#1 ,, The lines of code we wrote
to replace hardcoded bug status description with descriptions from new column
bug_status.description were about 50 LOC


For unit testing:

Selenium test will be generated for this case. it will be approximately 30 LOC
,, Usually in Selenium each action we perform in the web UI is one line of code
, like filling in an input box, clicking a button , verifying data each one of
those is one line of code ,, so by imagining the test and the number of actions
that will be done for this test , I would say it will take 30 LOC


so Total LOC = 50 + 30 = 80 LOC
Comment 3 Noura El hawary 2007-12-19 10:57:10 EST
Note ,, background for this ticket can be rt:
https://engineering.redhat.com/rt3/Ticket/Display.html?id=15551
Comment 4 Kevin Baker 2007-12-19 11:00:47 EST
Noura, when coming up with the LOC did you look at the upstream code to see if 
there had been major changes around the status field? In other words, is it as 
simple as copying the existing code from 2.18 to 3.2 or do you have to start 
again?
Comment 5 Noura El hawary 2007-12-19 12:11:46 EST
OK Looking at the 2.18 and 3.2 code basically in 2.18 most of the work to pull
out the bug_status description and generate the legal values for it is done in
globals.pl ,, however this file is deleted in 3.2 and its code is spreaded in
Bugzilla/*.pm modules ,, looking into those modules ,, I think that similar
amount of code that we have in the patch will be used to have that functionality
in 3.2 only it will be spread out in different modules Bugzilla/Field.pm ,
Bugzilla/Bug.pm and Bugzilla/Status.pm instead of globals.pl ,, and it should be
easy to add bug_status description to 3.2 and they have tidy well structured
Status.pm module that will ease the process.
Comment 6 Noura El hawary 2007-12-20 08:40:30 EST
Note changes selenium test estimation from LOC estimation to time estimation
Comment 7 Noura El hawary 2008-02-12 12:46:16 EST
Created attachment 294687 [details]
patch to pull out status description from bug status table

Please note that all this patch does is convert the multiple radio buttons of
the bug statuses to a single radio button with a drop down menu, and it
displays the status description when the mouse is moved over the status name in
the drop down menu. however bugzilla doesn't function properly with this patch
in terms of changing the status and the resolution.

for this patch to work 2 things are required:
1- table bug_status is created with description column and populated with the
status descriptions.
2- table status_workflow is populated with the right data that reflects redhat
bugzilla statuses.

Noura
Comment 8 Noura El hawary 2008-02-12 12:48:29 EST
3 hours analyzing the problem and figuring out how to convert our code to work
in the upstream code.
2 hours coding and testing
Comment 9 Noura El hawary 2008-02-14 09:11:20 EST
Created attachment 294911 [details]
bug status description patch

This patch should pull out the bug status description from the database table
bug_status if you move the mouse over bug status radio buttons it should
display the bug status description.

Noura
Comment 10 David Lawrence 2008-02-14 15:00:47 EST
Created attachment 294941 [details]
Bug status description patch (dkl)

Hey Noura, your patch looked good. I made a couple of changes and attached
another patch with the changes I made for you to look at.

1. I moved the mouse over title to the label so that if you hover over the
sentence "Change status to <STATUS>" it will display the title instead of just
the knob radio button.
2. I update editvalues.cgi and the the templates to allow us to edit the status
description from the admin UI. This way we wont need to bother sysadmins with
doing manual changes via SQL.

I have tested this patch on bugdev and all seems to work properly.

Let me know what you think.
Dave
Comment 11 Noura El hawary 2008-02-14 20:03:12 EST
Hi Dave,

The latest patch looks good :). I will commit it to cvs.

Thanks,
Noura
Comment 12 David Lawrence 2008-03-27 14:50:45 EDT
Comment on attachment 294911 [details]
bug status description patch

Clearing review flag for attachment 294911 [details] since 294941 was committed.
Comment 13 Noura El hawary 2008-11-12 01:09:10 EST
ignore comment please

Note You need to log in before you can comment on or make changes to this bug.