Bug 406241 - 3.14: OnHoldState and InProgressState for bug status.
3.14: OnHoldState and InProgressState for bug status.
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
2 hours
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 11:58 EST by David Lawrence
Modified: 2013-06-24 00:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 17:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2007-11-30 11:58:21 EST
Description:
Red Hat subroutines for returning a list of bug statuses that are considered either HOLD states or INPROGRESS states.

Function Requirements:
globals.pl
Comment 1 David Lawrence 2007-12-20 00:23:53 EST
LOC Estimation:

globals.pl: 14
showdependencytree.cgi: 2
test cases needed to test 2 functions * 20 lines average code: 40
time to write selenium tests needed for showdependencytree.cgi: 2 hours
templates: 6

Total LOC: 62
Comment 2 Kevin Baker 2008-04-14 21:52:21 EDT
Ben,

can you remind us if this is still necessary for the final release.
Comment 3 Benjamin Kahn 2008-04-14 23:33:46 EDT
This is for colorization of the dependency tree, right?

It can probably wait, I don't use this anymore since we don't tend to use
tracker bugs.  But others might be relying on it now.
Comment 4 David Lawrence 2008-04-14 23:39:53 EDT
(In reply to comment #3)
> This is for colorization of the dependency tree, right?
> 

Yes.

> It can probably wait, I don't use this anymore since we don't tend to use
> tracker bugs.  But others might be relying on it now.

Ok, i vote we remove it as a blocker for now and see if anyone speaks up.

Dave
Comment 5 Chris Ward 2009-04-02 01:59:57 EDT
Can I vote -? :-) What was the original use case here? Isn't this obtainable with simple boolean queries?
Comment 6 David Lawrence 2009-04-23 17:24:46 EDT
(In reply to comment #5)
> Can I vote -? :-) What was the original use case here? Isn't this obtainable
> with simple boolean queries?  

Yeah this was a cosmetic change to the dependency tree to show at a glance using color which bugs were in which stage of work. As Ben stated noone is really using this anymore and we haven't had it since 3.2 rolled out without complaint.

So will close this.

Dave

Note You need to log in before you can comment on or make changes to this bug.