This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 406331 - 3.23: !CheckCanChangeField() changes in process_bug.cgi
3.23: !CheckCanChangeField() changes in process_bug.cgi
Status: CLOSED DUPLICATE of bug 406141
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: Tony Fu
:
Depends On:
Blocks: RHBZ30UpgradeTracker 406141
  Show dependency treegraph
 
Reported: 2007-11-30 11:58 EST by David Lawrence
Modified: 2013-06-24 00:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 00:05:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2007-11-30 11:58:41 EST
Description:
Code sections in were added to process_bug.cgi for disallowing certain changes to external people to certain Red Hat products such as RHEL, RHEL Beta, and RHEL Public Beta. Non Red Hat employees are not allowed to close or set priority in those products.

Function Requirements:
!CheckCanChangeField in process_bug.cgi
Comment 1 Tony Fu 2007-12-19 22:06:02 EST
Size estimation:

Need to call !CheckCanChangeField in process_bug.cgi.  It expects 3 lines of code.

Test Unit:

One web page(20 lines) and one xmlrpc call (100 lines) need to be test.


Total LOC = 3+20+100=123
Comment 2 David Lawrence 2007-12-29 00:05:25 EST

*** This bug has been marked as a duplicate of 406141 ***

Note You need to log in before you can comment on or make changes to this bug.