Bug 406441 - 3.34: frontpage.cgi
3.34: frontpage.cgi
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
2 hours
:
Depends On:
Blocks: RHBZ30UpgradeTracker 427057
  Show dependency treegraph
 
Reported: 2007-11-30 11:59 EST by David Lawrence
Modified: 2013-06-24 00:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 23:49:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add frontpage to bz 3.0 (same functionality as 2.18) (v1) (32.18 KB, patch)
2008-05-06 16:57 EDT, David Lawrence
nelhawar: review+
kbaker: review+
Details | Diff

  None (edit)
Description David Lawrence 2007-11-30 11:59:06 EST
Description:
frontpage.cgi is a special dashboard type page that displays defects/features of interest for person viewing the page.

Function Requirements:
frontpage.cgi will need to be updated to work with the 3.0 code API to perform the many different searches required.
Comment 1 David Lawrence 2007-12-21 10:40:54 EST
LOC Estimation:

frontpage.cgi: 400
templates: 350
selenium test to verify proper operation of front page UI: 2 hours

LOC Total: 750
Comment 2 Kevin Baker 2008-04-14 22:18:39 EDT
Necessary for final release in some form.
Not for milestone 3.
Might be worth bringing up with our survey software.
Could we do an external survey via John Poelstra??
Comment 3 David Lawrence 2008-05-06 16:57:59 EDT
Created attachment 304689 [details]
Patch to add frontpage to bz 3.0 (same functionality as 2.18) (v1)

Adds "My Front Page" link to header also. Should show same bug lists as the
2.18 front page.

In the future this should be made more customizable.

Please review

Installed on https://bugdev.devel.redhat.com/bugzilla/frontpage.cgi

Thanks
Dave
Comment 4 Kevin Baker 2008-05-07 15:29:27 EDT
Comment on attachment 304689 [details]
Patch to add frontpage to bz 3.0 (same functionality as 2.18) (v1)

only had a quick look. Seems to have the same functionality as 2.18, good. 

Code wise I was wondering about all the hard coded bugzilla statuses. Probably
not so bad I guess.
Comment 5 David Lawrence 2008-05-07 15:46:07 EDT
Yeah it is very less than ideal. For now I just wanted to get same functionality
going as there will be people complaining if it is missing.

The whole dashboard concept will need to be revisited in the future and we can 
solicit requirements from Red Hat and community to see about coming up with
something much more configurable.

Checking in for now.

Thanks for the review
Dave
Comment 6 David Lawrence 2008-05-07 15:51:06 EDT
Checked into CVS.

Worked 3 hours.
Comment 7 Noura El hawary 2008-05-09 01:12:32 EDT
Comment on attachment 304689 [details]
Patch to add frontpage to bz 3.0 (same functionality as 2.18) (v1)

Hi Dave,

Patch looks good ad works fine for me. just a not i couldn't find file:
template/en/default/frontpage/main.html.tmpl
committed to cvs not sure if you left it intentionally

Noura
Comment 8 Noura El hawary 2008-05-09 05:51:00 EDT
Hi Dave,,

also one little thing in the code:

in frontpage.cgi line 78:

$vars->{'products_buffer'}
    =
"bug_status=NEW&bug_status=MODIFIED&bug_status=ASSIGNED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=RELEASE_PENDING&bug_status=POST&bug_status=FAILS_QA";

------
it is missing an '&' at the beginning for correct cgi query string:

$vars->{'products_buffer'}
    =
"&bug_status=NEW&bug_status=MODIFIED&bug_status=ASSIGNED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=RELEASE_PENDING&bug_status=POST&bug_status=FAILS_QA";


Noura
Comment 9 Noura El hawary 2008-05-09 06:14:45 EDT
and one last question Dave,, I just noticed that you treat the
assignedtoneedinfo different to reporedbyneedinfo, the assigned to you use the
NEEDINFO status where as in the reported by you use the flag needinfo in 2.18
both used NEEDINFO status so this would be the new behavior in 3.2? maybe this
is related to the needinfo bug ?

Noura
Comment 10 David Lawrence 2008-05-09 10:47:03 EDT
(In reply to comment #7)
> (From update of attachment 304689 [details] [edit])
> Hi Dave,
> 
> Patch looks good ad works fine for me. just a not i couldn't find file:
> template/en/default/frontpage/main.html.tmpl
> committed to cvs not sure if you left it intentionally
> 
> Noura
> 

It seems to be in the repository from what I can tell. When you are updating
are you using -d which creates new directories that did not exist before?

I normally do 'cvs -q up -dP' in the current checkout directory.

Dave 

Comment 11 David Lawrence 2008-05-09 11:06:44 EDT
(In reply to comment #8)

> it is missing an '&' at the beginning for correct cgi query string:
> 
> $vars->{'products_buffer'}
>     =
>
"&bug_status=NEW&bug_status=MODIFIED&bug_status=ASSIGNED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=RELEASE_PENDING&bug_status=POST&bug_status=FAILS_QA";

Oops, not sure how I left that off. I will add back before checking in.
Comment 12 David Lawrence 2008-05-09 11:19:46 EDT
(In reply to comment #9)
> and one last question Dave,, I just noticed that you treat the
> assignedtoneedinfo different to reporedbyneedinfo, the assigned to you use the
> NEEDINFO status where as in the reported by you use the flag needinfo in 2.18
> both used NEEDINFO status so this would be the new behavior in 3.2? maybe this
> is related to the needinfo bug ?
> 
> Noura

Another mistake. I have now checked in fixes for that which remove all instances
of NEEDINFO in frontpage.cgi and instead search for flag == needinfo? which is
used in 2.18 also anyway and now 3.2.

Note You need to log in before you can comment on or make changes to this bug.