Bug 40655 - xmms-1.2.4-15.src.rpm fails to rebuild
Summary: xmms-1.2.4-15.src.rpm fails to rebuild
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-15 09:56 UTC by Enrico Scholz
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 09:57:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-05-15 09:56:51 UTC
[autoconf-2.14.9-2]

Description of Problem:

When trying to rebuild the xmms-packages, the %build stage fails because
`autoheader' creates a tmp-files exceeding the capacity of /tmp (around
150MB). Same thing happens when calling `autoconf' in the build-dir.

Because autoconf-2.13 and autoconf-2.49f-1 are working fine, I think it is
an autoconf-issue but not an xmms one.


How Reproducible:

everytime


Steps to Reproduce:
1. rpm --rebuild xmms-1.2.4-15.src.rpm

or

1. rpm -U xmms-1.2.4-15.src.rpm; rpm -bp /usr/src/redhat/SPECS/xmms.spec;
cd /usr/src/redhat/BUILD/xmms-1.2.4/
2. autoconf


Actual Results:
...
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.78762
+ autoheader
configure.in:35: /usr/bin/m4: ERROR: Copying inserted file: No space left
on device
error: AC_CONFIG_HEADER not found in configure.in
error: Bad exit status from /var/tmp/rpm-tmp.78762 (%build)
    Bad exit status from /var/tmp/rpm-tmp.78762 (%build)


Expected Results:


Additional Information:
$ df /
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda10              256667     72926    157237  32% /

Comment 1 Bernhard Rosenkraenzer 2001-05-15 12:09:16 UTC
Autoheader is looping on a broken construct in acgeneral.m4.
Fixed in 2.14.9-3


Note You need to log in before you can comment on or make changes to this bug.