Bug 40656 - Bad multibyte chars in japanese .po-file
Summary: Bad multibyte chars in japanese .po-file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xmms   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-15 10:24 UTC by Enrico Scholz
Modified: 2014-03-17 02:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 19:50:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-05-15 10:24:42 UTC
[xmms-1.2.4-15.src.rpm]

Description of Problem:

xmms fails to rebuild because msgfmt fails on po/ja.po.


How Reproducible:

everytime


Steps to Reproduce:
1. LANG=C rpm --rebuild xmms-1.2.4-15.src.rpm

Actual Results:
...
file=./`echo ja | sed 's,.*/,,'`.gmo \
  && rm -f $file && PATH=../src:$PATH /usr/bin/msgfmt -o $file ja.po
ja.po:1675: invalid multibyte sequence
ja.po:3110: invalid multibyte sequence
ja.po:3167: invalid multibyte sequence
ja.po:3212: invalid multibyte sequence
ja.po:3265: invalid multibyte sequence
found 5 fatal errors
make[2]: *** [ja.gmo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2
...

Additional Information:
$ rpm -q gettext glibc
gettext-0.10.37-2
glibc-2.2.2-10

$LINGUAS is unset

Comment 1 Bill Nottingham 2001-05-15 16:10:10 UTC
Hm, it builds fine with the 7.1 gettext. Trond, has gettext changed significantly
in this regard?

Comment 2 Håvard Kvålen 2001-05-16 19:43:12 UTC
The strings it fails on are input strings.  These are in ISO-8859-1 and does
indeed contain sequences that are not legal EUC-JP.

Comment 3 Trond Eivind Glomsrxd 2001-05-16 19:50:10 UTC
Yes, gettext has changed significantly wrt. handling of Japanese (multibyte) -
to use the old style, use  OLD_PO_FILE_INPUT=yes

Comment 4 Bill Nottingham 2001-06-19 20:25:09 UTC
This should be fixed in the current rawhide xmms (1.2.4-16)


Note You need to log in before you can comment on or make changes to this bug.