Bug 406971 - upgrade fc7-fc8 makes remote login via xdmcp disappear
upgrade fc7-fc8 makes remote login via xdmcp disappear
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
8
i586 Linux
low Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 16:32 EST by Ray Todd Stevens
Modified: 2007-12-17 10:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 10:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2007-11-30 16:32:41 EST
Description of problem:

I upgraded from fc7 to fc8 and was using the remote login via xdmcp function on
the unloggedin screen to manage various servers.   The problem is that when I
upgraded this option disappeared from the login screen.   I checked it is still
set as active on second tab of the the login window settings.   I also can't
find a way to activate it and make it work.

These may be two different issues.   That is the fact that it disappeared, and
that you can't now activate it.   But frankly I doubt it.   I do have the same
problem with a newly installed fc8 server where I can't find a way to activate this,


Version-Release number of selected component (if applicable):

gdm 2.20.1-7.fc8

How reproducible:

Seems to be 100% with low sample set.
Comment 1 Ray Todd Stevens 2007-12-01 19:20:01 EST
OK I have more information.   This problem seems to be related to "themes".

Using the "plain" version of the login works right.

Using the "circles" version also works however the display is a little
"interesting"   There are is an extra blank at the bottom that is in fact blank
and then does things when you click on it.

"infinity" definitely doesn't work!!!!

Happy gnome works with the problem mentioned above.

the one with "browser" does to.

Comment 2 Ray Todd Stevens 2007-12-14 00:05:50 EST
OK I played with the problem some more.   I found a whole lot out and sure
learned a lot.   One of the things I learned is that I am not very good at XML.
:-(  But more important I also learned that the problem is in an xml file.  
There is a file FedoraInfinityGDM.xml in /usr/shared/gdm/themes/FedoraInfinity

I played around with the select button and founded that using information from
the circles version I could make an options button that kind of worked.  
Actually "mechanically"  it worked but was butt ugly so I am not sure I want to
show my code unless absolutely necessary.   If someone who knows xml could setup
a button that actually looks pretty with a "standard type" of "options" I think
this could be fixed pretty easy.
Comment 3 Ray Strode [halfline] 2007-12-17 10:56:58 EST
Hi Ray,

The default theme doesn't expose that functionality, but you can get at it by
using a different theme or by pressing F10.

The feature is sort of specialized (good for managing servers, but not for the
typical case), so we probably wouldn't add it back to the default theme.

Note You need to log in before you can comment on or make changes to this bug.