This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 406981 - md5sum has 'text' and 'binary' options which do nothing.
md5sum has 'text' and 'binary' options which do nothing.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 16:37 EST by David Woodhouse
Modified: 2008-01-26 13:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-26 13:16:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2007-11-30 16:37:53 EST
The 'text' and 'binary' options to md5sum do nothing, and are confusing. Perhaps
we can't remove them, in case people have scripts which use them -- but we
should at least make sure that 'md5sum --help' and the man page make it clear
that they do nothing on real computers.
Comment 1 Ondrej Vasik 2008-01-26 13:16:12 EST
It is not always true that they do nothing. They do nothing on GNU system -
where text and binary file style is the same. More detailed informations about
those options are in 'info md5sum' (in some cases is necessary to use both - man
and info pages - coreutils have usually more informations on info pages). Anyway
- those options are not depricated even in the latest upstream release and are
used for compatibility with systems where binary and text differ(like MS-DOS). I
don't think that it is useful to create patch which will only remove all the
text about -t / -b option from man,info and help page and to keep it forever in
Fedora package - because I doubt that will get accepted by upstream. It could be
IMHO even more confusing for users(if options -t/-b are accepted, but not shown
in man/info/help). So closing NOTABUG, but feel free to add your comments (maybe
it could be more helpful to add something to man/help page what will say that
text and binary options will have same output on GNU system).

Note You need to log in before you can comment on or make changes to this bug.