Bug 407 - afterstep config changes not saved
afterstep config changes not saved
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: AfterStep (Show other bugs)
5.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-14 02:33 EST by deivu
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-14 13:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description deivu 1998-12-14 02:33:19 EST
Any changes I make to the ~/GNUstep/Library/Afterstep/start/
hierarchy are erased the next time I start X.
Comment 1 David Lawrence 1998-12-14 12:46:59 EST
I have verified this to be a problem. If you make the changes to the
start directory and then startx, the changes are removed and it starts
with a default setup. If you make the changes to the start directory
from an xterm and then just choose 'restart session' the changes are
left intact and the menu behaves properly.
Comment 2 Cristian Gafton 1998-12-14 13:21:59 EST
That is because of the wmconfig processing that will take palce in
that directory. The start dir is created/controlled by wmconfig
entirely.

In the 5.2 this problem was fixed by having the ability to create a
"fixed" dir on the same level with the start dir that will include
changes to the menu structure.

Note You need to log in before you can comment on or make changes to this bug.